aboutsummaryrefslogtreecommitdiffstats
path: root/math/scalapack
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2015-08-18 18:51:01 +0800
committerrakuco <rakuco@FreeBSD.org>2015-08-18 18:51:01 +0800
commit4f4c3f4858e41faac2d9b5883898c35afbe1c327 (patch)
treece0de1d0b7bda5eb762e64fe58300177d350898c /math/scalapack
parent8a49f8f056abc122912107313fddc7b1ea728c39 (diff)
downloadfreebsd-ports-gnome-4f4c3f4858e41faac2d9b5883898c35afbe1c327.tar.gz
freebsd-ports-gnome-4f4c3f4858e41faac2d9b5883898c35afbe1c327.tar.zst
freebsd-ports-gnome-4f4c3f4858e41faac2d9b5883898c35afbe1c327.zip
Uses/cmake.mk: Replace CMAKE_ENV with CONFIGURE_ENV.
Instead of defining a variable that is almost always based on CONFIGURE_ENV, just use CONFIGURE_ENV directly. This also matches the behavior of other ports that do not use autotools (so most ports can just worry about CONFIGURE_ENV). Additionally, the fact that we do not use ?= means we do not have problems if another file in Uses/ needs to set CONFIGURE_ENV (with CMAKE_ENV, the order of the arguments to USES would matter). Ports which set CMAKE_ENV have been adjusted accordingly. In most cases, CMAKE_ENV was just replaced with CONFIGURE_ENV, the exceptions being: * databases/sqliteman: CMAKE_ENV line removed; setting QMAKESPEC there has no effect on the build system. * devel/freeocl: CMAKE_ENV line removed; FREEOCL_CXX_COMPILER is already retrieved from the CMAKE_CXX_COMPILER variable in the build system. * graphics/openimageio: CMAKE_ENV line removed; setting Qt variables there has no effect on the build system. Reviewed by: makc Differential Revision: https://reviews.freebsd.org/D3403
Diffstat (limited to 'math/scalapack')
-rw-r--r--math/scalapack/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/math/scalapack/Makefile b/math/scalapack/Makefile
index 8bb5c3966d69..312d89639ed0 100644
--- a/math/scalapack/Makefile
+++ b/math/scalapack/Makefile
@@ -112,7 +112,7 @@ post-build:
${RM} -rf ${WRKSRC}/CMakeFiles ${WRKSRC}/CMakeCache.txt
${CP} -p ${WRKSRC}/Makefile.dist ${WRKSRC}/Makefile
(cd ${WRKSRC} && \
- ${SETENV} ${CMAKE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS:C|BUILD_STATIC_LIBS|BUILD_SHARED_LIBS|} ${CMAKE_SOURCE_PATH})
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS:C|BUILD_STATIC_LIBS|BUILD_SHARED_LIBS|} ${CMAKE_SOURCE_PATH})
(cd ${WRKSRC} && ${DO_MAKE_BUILD} ${ALL_TARGET})
post-install: