aboutsummaryrefslogtreecommitdiffstats
path: root/math/scalapack
diff options
context:
space:
mode:
authoradridg <adridg@FreeBSD.org>2017-12-23 18:44:23 +0800
committeradridg <adridg@FreeBSD.org>2017-12-23 18:44:23 +0800
commit8aaab2f98634f774e392d192523d6a3ae3a73a58 (patch)
treef01e4cd9ef2c99decd0b26c2e6a9d905c7d10777 /math/scalapack
parent4a88f4bb8f71b83c7d44ba9d81d6c46ae854f776 (diff)
downloadfreebsd-ports-gnome-8aaab2f98634f774e392d192523d6a3ae3a73a58.tar.gz
freebsd-ports-gnome-8aaab2f98634f774e392d192523d6a3ae3a73a58.tar.zst
freebsd-ports-gnome-8aaab2f98634f774e392d192523d6a3ae3a73a58.zip
Update CMake to 3.10.1
- https://blog.kitware.com/cmake-3-10-1-available-for-download/ - flang support - changes to automoc policies - support for FreeBSD package generation with CPack Necessary fixes to other ports: - cad/openvsp make search for libxml explicit - math/scalapack force C compiler to be compatible with mpi - deskutils/kdepim4 fix incorrect sources list - www/qt5-webkit fix incorrect sources list Thanks to Antoine for the multiple exp-runs. PR: 223872 Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D13210
Diffstat (limited to 'math/scalapack')
-rw-r--r--math/scalapack/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/math/scalapack/Makefile b/math/scalapack/Makefile
index 6c5c23bd80cd..92ade1f7329c 100644
--- a/math/scalapack/Makefile
+++ b/math/scalapack/Makefile
@@ -100,6 +100,10 @@ MPIF77= ${LOCALBASE}/bin/mpif77
MPICC= ${LOCALBASE}/bin/mpicc
.endif
+# USES=fortran already forces FC to a supported fortran compiler;
+# assume mpicc points to a compatible compiler and force that, too.
+CC= ${MPICC}
+
pre-configure:
${CP} -p ${WRKSRC}/Makefile ${WRKSRC}/Makefile.dist
${CP} ${WRKSRC}/SLmake.inc.example ${WRKSRC}/SLmake.inc