aboutsummaryrefslogtreecommitdiffstats
path: root/math/scigraphica/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-08-29 20:43:07 +0800
committersobomax <sobomax@FreeBSD.org>2000-08-29 20:43:07 +0800
commit417eff86ff8142270d252e76a834ac88043eef6f (patch)
treefa1965960c0f2f1c9c5e45ec82b07eb08397949d /math/scigraphica/Makefile
parent38ff42f2311e9d90a4d39630b39fe64a16a5eb43 (diff)
downloadfreebsd-ports-gnome-417eff86ff8142270d252e76a834ac88043eef6f.tar.gz
freebsd-ports-gnome-417eff86ff8142270d252e76a834ac88043eef6f.tar.zst
freebsd-ports-gnome-417eff86ff8142270d252e76a834ac88043eef6f.zip
Add scigraphica - a scientific application for data analysis and technical
graphics for Gnome desktop.
Diffstat (limited to 'math/scigraphica/Makefile')
-rw-r--r--math/scigraphica/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/math/scigraphica/Makefile b/math/scigraphica/Makefile
new file mode 100644
index 000000000000..e50aea6f6117
--- /dev/null
+++ b/math/scigraphica/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: scigraphica
+# Date created: 29 August 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scigraphica
+PORTVERSION= 0.4
+CATEGORIES= math gnome
+MASTER_SITES= http://magnet.fsu.edu/~feiguin/scigraphica/src/
+DISTNAME= sg-${PORTVERSION}
+
+MAINTAINER= sobomax@FreeBSD.org
+
+BUILD_DEPENDS= python:${PORTSDIR}/lang/python
+LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
+ gtkextra.10:${PORTSDIR}/x11-toolkits/gtkextra \
+ xml.5:${PORTSDIR}/textproc/libxml
+RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore \
+ python:${PORTSDIR}/lang/python
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>