aboutsummaryrefslogtreecommitdiffstats
path: root/math/scigraphica
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-05-03 17:02:06 +0800
committersobomax <sobomax@FreeBSD.org>2001-05-03 17:02:06 +0800
commit0f38f2908eff1a457e50963c6557a08fca1077ad (patch)
tree65212dd0c74793ad2205a18e8a34c91a19506fad /math/scigraphica
parent305d8b89ab984b30c9e13607e76af8a1df9c249b (diff)
downloadfreebsd-ports-gnome-0f38f2908eff1a457e50963c6557a08fca1077ad.tar.gz
freebsd-ports-gnome-0f38f2908eff1a457e50963c6557a08fca1077ad.tar.zst
freebsd-ports-gnome-0f38f2908eff1a457e50963c6557a08fca1077ad.zip
Fix another victim of recent py-numeric change.
Diffstat (limited to 'math/scigraphica')
-rw-r--r--math/scigraphica/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/math/scigraphica/Makefile b/math/scigraphica/Makefile
index d924cf20e833..43ab4e3b0c3a 100644
--- a/math/scigraphica/Makefile
+++ b/math/scigraphica/Makefile
@@ -16,10 +16,10 @@ DISTNAME= sg-${PORTVERSION}
MAINTAINER= sobomax@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/include/${PYTHON_VERSION}/Numeric/arrayobject.h:${PORTSDIR}/math/numpy
+BUILD_DEPENDS= ${PYNUMERIC}
LIB_DEPENDS= gtkextra.14:${PORTSDIR}/x11-toolkits/gtkextra \
xml.5:${PORTSDIR}/textproc/libxml
-RUN_DEPENDS= ${LOCALBASE}/include/${PYTHON_VERSION}/Numeric/arrayobject.h:${PORTSDIR}/math/numpy
+RUN_DEPENDS= ${PYNUMERIC}
USE_X_PREFIX= yes
USE_GMAKE= yes
@@ -29,6 +29,14 @@ USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_VERSION} == "python2.1"
+PYNUMERIC= ${LOCALBASE}/include/${PYTHON_VERSION}/Numeric/arrayobject.h:${PORTSDIR}/math/py-numeric
+.else
+PYNUMERIC= ${LOCALBASE}/include/${PYTHON_VERSION}/Numeric/arrayobject.h:${PORTSDIR}/math/py-numeric17
+.endif
+
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@@ -36,4 +44,4 @@ pre-patch:
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>