aboutsummaryrefslogtreecommitdiffstats
path: root/math/scilab-toolbox-swt
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-01-23 15:52:04 +0800
committermiwi <miwi@FreeBSD.org>2007-01-23 15:52:04 +0800
commit13f663cb1fe3a0590b7c665deaaf33c43dd46be5 (patch)
tree3b7f461725fa3bbf057980fabf862e1b455f78e8 /math/scilab-toolbox-swt
parentcdf6c9300ccd4b2d8e426c61cce46079012c9898 (diff)
downloadfreebsd-ports-gnome-13f663cb1fe3a0590b7c665deaaf33c43dd46be5.tar.gz
freebsd-ports-gnome-13f663cb1fe3a0590b7c665deaaf33c43dd46be5.tar.zst
freebsd-ports-gnome-13f663cb1fe3a0590b7c665deaaf33c43dd46be5.zip
- Fix build with gfortran
- Bump PORTREVISION Submitted by: pointyhat via kris Thanks To: maho@ for fix
Diffstat (limited to 'math/scilab-toolbox-swt')
-rw-r--r--math/scilab-toolbox-swt/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/math/scilab-toolbox-swt/Makefile b/math/scilab-toolbox-swt/Makefile
index 37627d7bcb0e..3a4cd6d1bec8 100644
--- a/math/scilab-toolbox-swt/Makefile
+++ b/math/scilab-toolbox-swt/Makefile
@@ -7,6 +7,7 @@
PORTNAME= swt
PORTVERSION= 0.1.0.r3
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= scwt
@@ -16,9 +17,15 @@ DISTNAME= ${PORTNAME}-0.1.0rc3
MAINTAINER= makc@issp.ac.ru
COMMENT= Scilab 1-D and 2-D Wavelet Toolbox
-BUILD_DEPENDS= scilab:${PORTSDIR}/math/scilab
+BUILD_DEPENDS+= scilab:${PORTSDIR}/math/scilab
-INSTALLS_SHLIB= yes
+WANT_FORTRAN= yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
+CONFIGURE_ENV+= FC="${FC}" F77="${F77}" FFLAGS="${FFLAGS}"
+
+USE_LDCONFIG= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib/scilab/contrib/swt/lib
HAS_CONFIGURE= yes