aboutsummaryrefslogtreecommitdiffstats
path: root/math/scilab/Makefile
diff options
context:
space:
mode:
authortruckman <truckman@FreeBSD.org>2016-05-07 05:45:19 +0800
committertruckman <truckman@FreeBSD.org>2016-05-07 05:45:19 +0800
commitbcd28d3245e6a9fb4bdcaf32f987c11819845901 (patch)
treee1ec7b8e8911dcd7b96cae5da3ffa38b471be2c4 /math/scilab/Makefile
parent7ff6a46f7b27e88d02db93e246c6ef1a28376cc0 (diff)
downloadfreebsd-ports-gnome-bcd28d3245e6a9fb4bdcaf32f987c11819845901.tar.gz
freebsd-ports-gnome-bcd28d3245e6a9fb4bdcaf32f987c11819845901.tar.zst
freebsd-ports-gnome-bcd28d3245e6a9fb4bdcaf32f987c11819845901.zip
Fix build with science/hdf5 version 1.10 by specifying that we want to
use the version 1.8 API. Fix the build when the GUI option is disabled. Since this port installs icons, add INSTALLS_ICONS=yes to Makefile. PR: 209244 Approved by: makc (maintainer)
Diffstat (limited to 'math/scilab/Makefile')
-rw-r--r--math/scilab/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index 4cec89047d39..5c927da21c01 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -27,6 +27,8 @@ USES= cpe desktop-file-utils fortran gettext gmake iconv \
libtool pathfix pkgconfig shared-mime-info
GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-gfortran \
@@ -118,7 +120,7 @@ CONFIGURE_ARGS+= --without-openmp
.include <bsd.port.pre.mk>
-.if ${JAVA_PORT_VERSION:M1.8.*}
+.if ${PORT_OPTIONS:MGUI} && ${JAVA_PORT_VERSION:M1.8.*}
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-Makefile.in
.endif