aboutsummaryrefslogtreecommitdiffstats
path: root/math/scilab/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-11-27 09:38:31 +0800
committersteve <steve@FreeBSD.org>1999-11-27 09:38:31 +0800
commitec7e42b0aa2ab100debbf1415c0504de85b0803a (patch)
tree5f8c132322f394bcab2e0ca9b772b7cc931efd93 /math/scilab/Makefile
parent0eede4784309008b5791b7fbcf6882be1259f879 (diff)
downloadfreebsd-ports-gnome-ec7e42b0aa2ab100debbf1415c0504de85b0803a.tar.gz
freebsd-ports-gnome-ec7e42b0aa2ab100debbf1415c0504de85b0803a.tar.zst
freebsd-ports-gnome-ec7e42b0aa2ab100debbf1415c0504de85b0803a.zip
Update to version 2.4.1.
PR: 14877 Submitted by: Pedro F. Giffuni <pfgiffun@bachue.usc.unal.edu.co>
Diffstat (limited to 'math/scilab/Makefile')
-rw-r--r--math/scilab/Makefile22
1 files changed, 13 insertions, 9 deletions
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index b5a8d24b3462..f6eb0e5a428d 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -1,29 +1,33 @@
# New ports collection makefile for: Scilab
-# Version required: 2.3
+# Version required: 2.4.1
# Date created: 13 June 1997
# Whom: paulo@isr.uc.pt
#
# $FreeBSD$
#
-DISTNAME= scilab-2.3.1
-PKGNAME= Scilab-2.3.1
+DISTNAME= scilab-${SCILAB_VER}
+PKGNAME= Scilab-${SCILAB_VER}
CATEGORIES= math cad
-MASTER_SITES= ftp://ftp.inria.fr/INRIA/Projects/Meta2/Scilab/
+MASTER_SITES= ftp://ftp.inria.fr/INRIA/Projects/Meta2/Scilab/distributions/
EXTRACT_SUFX= -src.tar.gz
MAINTAINER= paulo@isr.uc.pt
-RUN_DEPENDS= xless:${PORTSDIR}/misc/xless
+RUN_DEPENDS= pvm:${PORTSDIR}/net/pvm \
+ xless:${PORTSDIR}/misc/xless
-BROKEN= package
+SCILAB_VER= 2.4.1
+PLIST_SUB+= SCILAB_VER=${SCILAB_VER}
NO_CDROM= "Don't sell for profit."
-WRKSRC= ${WRKDIR}/scilab-2.3
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
USE_X_PREFIX= yes
-SCIDIR= ${X11BASE}/lib/X11/scilab
+MAKE_ENV= SCIDIR=${PREFIX}/lib/X11/$(DISTNAME)
+
+pre-install:
+ @(cd $(WRKSRC); ${RM} -rf Win95-util *.orig)
post-install:
@${CAT} ${PKGMESSAGE}