aboutsummaryrefslogtreecommitdiffstats
path: root/math/sdpa
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2004-08-18 19:12:34 +0800
committermaho <maho@FreeBSD.org>2004-08-18 19:12:34 +0800
commit9e52560554354bd785ce4e5bc09e3a6568494d28 (patch)
tree92b9e0ab3a00354011585b0aade52461351e795b /math/sdpa
parent31e68109a03bf2b28c7258dd81553b579d42192c (diff)
downloadfreebsd-ports-gnome-9e52560554354bd785ce4e5bc09e3a6568494d28.tar.gz
freebsd-ports-gnome-9e52560554354bd785ce4e5bc09e3a6568494d28.tar.zst
freebsd-ports-gnome-9e52560554354bd785ce4e5bc09e3a6568494d28.zip
o Add WITH_SMP, ATLAS with SMP support. currently serious
perfomance loss is observed. o change Intel C++ compiler flags to approprate one.
Diffstat (limited to 'math/sdpa')
-rw-r--r--math/sdpa/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/math/sdpa/Makefile b/math/sdpa/Makefile
index 9fedf556c723..ec2f817df652 100644
--- a/math/sdpa/Makefile
+++ b/math/sdpa/Makefile
@@ -33,8 +33,14 @@ USE_REINPLACE= yes
USE_GMAKE= yes
USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-LAPACK= -lalapack
-CBLAS= -lcblas -lf77blas -latlas -lg2c
+.if defined(WITH_SMP)
+LAPACK= -lalapack_r
+CBLAS= -lptcblas -lptf77blas -latlas_r -lg2c ${PTHREAD_LIBS}
+.else
+LAPACK= -static -lalapack
+CBLAS= -static -lcblas -lf77blas -latlas -lg2c
+.endif
+#WITH_SMP= yes
#WITH_ICC= yes
.if defined(WITH_OPTIMIZED_FLAGS)
@@ -49,8 +55,8 @@ CXXFLAGS+= -mcpu=i686 -march=i686 -mfancy-math-387 -mpreferred-stack-boundary=3
.if defined(WITH_ICC)
CC= ${LOCALBASE}/intel_cc_80/bin/icc
CXX= ${LOCALBASE}/intel_cc_80/bin/icpc
-CFLAGS= -O3 -tpp7 -xiMKW -Vaxlib
-CXXFLAGS= -O3 -tpp7 -xiMKW -Vaxlib
+CFLAGS= -O3 -tpp7 -axN -Vaxlib
+CXXFLAGS= -O3 -tpp7 -axN -Vaxlib
.endif
pre-build: