aboutsummaryrefslogtreecommitdiffstats
path: root/math/sdpa
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2010-02-16 14:04:31 +0800
committermaho <maho@FreeBSD.org>2010-02-16 14:04:31 +0800
commit71db4453f495bc30d4fef5683049af5cf26c06c2 (patch)
tree937703d6dcf2e55f630d13c4c36d88224fcbb174 /math/sdpa
parente7742bb9daf387c1002339d81ba355d47c5d07d9 (diff)
downloadfreebsd-ports-gnome-71db4453f495bc30d4fef5683049af5cf26c06c2.tar.gz
freebsd-ports-gnome-71db4453f495bc30d4fef5683049af5cf26c06c2.tar.zst
freebsd-ports-gnome-71db4453f495bc30d4fef5683049af5cf26c06c2.zip
Build fix with gotoblas.
Feature safe: yes
Diffstat (limited to 'math/sdpa')
-rw-r--r--math/sdpa/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/math/sdpa/Makefile b/math/sdpa/Makefile
index a07baba01d52..8b5da3c04dfb 100644
--- a/math/sdpa/Makefile
+++ b/math/sdpa/Makefile
@@ -26,7 +26,7 @@ USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}.${PORTVERSION}.src
USE_BLAS?= reference
-.if exists(${LOCALBASE}/lib/libgoto.so)
+.if exists(${LOCALBASE}/lib/libgoto2.so)
USE_BLAS= gotoblas
.elif exists(${LOCALBASE}/lib/libatlas_r.so)
USE_BLAS= atlas
@@ -38,10 +38,10 @@ LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
.elif ${USE_BLAS} == gotoblas
-LIB_DEPENDS+= goto:${PORTSDIR}/math/gotoblas
+LIB_DEPENDS+= goto2:${PORTSDIR}/math/gotoblas
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
-BLAS= -lgotop
-LAPACK= -lgotop -llapack
+BLAS= -lgoto2p
+LAPACK=
.elif ${USE_BLAS} == atlas
LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
BLAS= -lptf77blas -lptcblas -latlas_r