aboutsummaryrefslogtreecommitdiffstats
path: root/math/sdpa
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-01-13 07:42:19 +0800
committermaho <maho@FreeBSD.org>2007-01-13 07:42:19 +0800
commite0df0f9d060ddb121cfe2014f919a2ff14c2d1f5 (patch)
treed9b807c24b6a0ff62e0bfcb51ee1a12916e34712 /math/sdpa
parent000941a759c6736936e7e86a50e7de2c0eeea5aa (diff)
downloadfreebsd-ports-gnome-e0df0f9d060ddb121cfe2014f919a2ff14c2d1f5.tar.gz
freebsd-ports-gnome-e0df0f9d060ddb121cfe2014f919a2ff14c2d1f5.tar.zst
freebsd-ports-gnome-e0df0f9d060ddb121cfe2014f919a2ff14c2d1f5.zip
Still lapack.h and blas.h are required, though remove dependency
of g2c.h.
Diffstat (limited to 'math/sdpa')
-rw-r--r--math/sdpa/Makefile10
-rw-r--r--math/sdpa/files/patch-rsdpa_include.h2
2 files changed, 6 insertions, 6 deletions
diff --git a/math/sdpa/Makefile b/math/sdpa/Makefile
index 16f8f3daa8ef..c28566e93737 100644
--- a/math/sdpa/Makefile
+++ b/math/sdpa/Makefile
@@ -34,11 +34,11 @@ OLDVERSION= 6.2.0
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-#Atlas is always required as lapack.h and blas.h is required.
-#no blaswarp.h at the moment.
-LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
-
-WITH_ATLAS= yes
+#for f2c.h
+BUILD_DEPENDS= ${LOCALBASE}/lib/libf2c.a:${PORTSDIR}/lang/f2c
+#.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
+WITH_ATLAS= yes
+#.endif
.if defined(WITH_ATLAS)
BLAS= -lcblas -lf77blas -latlas
LAPACK= -lalapack
diff --git a/math/sdpa/files/patch-rsdpa_include.h b/math/sdpa/files/patch-rsdpa_include.h
index e27d3efbe5a4..b7eb5cbb2753 100644
--- a/math/sdpa/files/patch-rsdpa_include.h
+++ b/math/sdpa/files/patch-rsdpa_include.h
@@ -5,7 +5,7 @@
extern "C" {
-#include <f2c.h>
-+#include <g2c.h>
++#include <f2c.h>
#if NON_ATLAS_SDPA
#include <blaswrap.h>
#endif