aboutsummaryrefslogtreecommitdiffstats
path: root/math/sdpara
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2006-11-19 14:48:16 +0800
committermaho <maho@FreeBSD.org>2006-11-19 14:48:16 +0800
commit1c1acccc2f6d2ac3b9271145f43dd06a47814d26 (patch)
treeafa368d13a34c49bfaae34fd9d2f04f25578ec4c /math/sdpara
parentd4a01d98ad20803645d31f32fab207621ff30dfe (diff)
downloadfreebsd-ports-gnome-1c1acccc2f6d2ac3b9271145f43dd06a47814d26.tar.gz
freebsd-ports-gnome-1c1acccc2f6d2ac3b9271145f43dd06a47814d26.tar.zst
freebsd-ports-gnome-1c1acccc2f6d2ac3b9271145f43dd06a47814d26.zip
Fix build error. Now blacs/scalapack are linked
against mpich2, and sdpara should not link against mpich. Mixing mpich2/mpich caused an error. PR: 105550
Diffstat (limited to 'math/sdpara')
-rw-r--r--math/sdpara/Makefile2
-rw-r--r--math/sdpara/files/patch-Makefile6
2 files changed, 4 insertions, 4 deletions
diff --git a/math/sdpara/Makefile b/math/sdpara/Makefile
index 41510111d019..61356228dacd 100644
--- a/math/sdpara/Makefile
+++ b/math/sdpara/Makefile
@@ -22,7 +22,7 @@ COMMENT= SDPARA paralell version of SDPA (math/sdpa)
LIB_DEPENDS= atlas:${PORTSDIR}/math/atlas
BUILD_DEPENDS= ${LOCALBASE}/lib/libscalapack.a:${PORTSDIR}/math/scalapack \
${LOCALBASE}/lib/libblacs.a:${PORTSDIR}/math/blacs \
- ${LOCALBASE}/mpich/lib/libmpich.a:${PORTSDIR}/net/mpich
+ ${LOCALBASE}/mpich2/lib/libmpich.a:${PORTSDIR}/net/mpich2
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/math/sdpara/files/patch-Makefile b/math/sdpara/files/patch-Makefile
index e6632c3469d3..770cd5aeef7b 100644
--- a/math/sdpara/files/patch-Makefile
+++ b/math/sdpara/files/patch-Makefile
@@ -20,12 +20,12 @@
-MPIBIN=
-CC = $(MPIBIN)mpicxx
-+MPIBIN= %%LOCALBASE%%/mpich/bin/
-+CC = $(MPIBIN)mpiCC
++MPIBIN= %%LOCALBASE%%/mpich2/bin/
++CC = $(MPIBIN)mpicxx
F77 = $(MPIBIN)mpif77
OPTION = -O3 #-g
+FFLAGS = %%FFLAGS%%
-+CXXFLAGS = %%CXXFLAGS%%
++CXXFLAGS = %%CXXFLAGS%% -DMPICH_IGNORE_CXX_SEEK
TARGET_EXE = $(RSDPA_LIB_NAME)
#TARGET_EXE = rsdpa_main.exe