aboutsummaryrefslogtreecommitdiffstats
path: root/math/sdpara
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2004-11-23 10:10:49 +0800
committermaho <maho@FreeBSD.org>2004-11-23 10:10:49 +0800
commit4293e529c636bf29e8e11b9be5dd8ef066c20528 (patch)
treef14e6fa0ea8f5d576ec2799e444985a3444f5262 /math/sdpara
parent8abd89583551e7a9726dc009d4001b21743fbb5c (diff)
downloadfreebsd-ports-gnome-4293e529c636bf29e8e11b9be5dd8ef066c20528.tar.gz
freebsd-ports-gnome-4293e529c636bf29e8e11b9be5dd8ef066c20528.tar.zst
freebsd-ports-gnome-4293e529c636bf29e8e11b9be5dd8ef066c20528.zip
Fix build with WITH_OPTIMIZED_FLAGS
PR: 74011 Submitted by: Jie Gao <gaoj at cpsc.ucalgary.ca>
Diffstat (limited to 'math/sdpara')
-rw-r--r--math/sdpara/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/math/sdpara/Makefile b/math/sdpara/Makefile
index acff74377a3a..4538b1e2b9e5 100644
--- a/math/sdpara/Makefile
+++ b/math/sdpara/Makefile
@@ -33,6 +33,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
LAPACK= -lalapack
CBLAS= -lcblas -lf77blas -latlas -lg2c
+.include <bsd.port.pre.mk>
+
.if defined(WITH_OPTIMIZED_FLAGS)
FFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double
CXXFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double -Wno-multichar
@@ -72,4 +74,4 @@ do-install:
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>