aboutsummaryrefslogtreecommitdiffstats
path: root/math/sdpara
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-03-25 15:37:15 +0800
committermarino <marino@FreeBSD.org>2015-03-25 15:37:15 +0800
commite59c5e2e130d16dc7ae04b960115c07010eaed3a (patch)
tree3417a6e6d1d00e03135a08921179dc70e19d3610 /math/sdpara
parent4d9897388d9ae31e9dd0adf6df18eba800f8b154 (diff)
downloadfreebsd-ports-gnome-e59c5e2e130d16dc7ae04b960115c07010eaed3a.tar.gz
freebsd-ports-gnome-e59c5e2e130d16dc7ae04b960115c07010eaed3a.tar.zst
freebsd-ports-gnome-e59c5e2e130d16dc7ae04b960115c07010eaed3a.zip
math category: Remove $PTHREAD_LIBS
Note that math/PDL did not pass stage-QA before, so it was fixed. approved by: PTHREAD blanket
Diffstat (limited to 'math/sdpara')
-rw-r--r--math/sdpara/Makefile1
-rw-r--r--math/sdpara/files/patch-Makefile10
2 files changed, 4 insertions, 7 deletions
diff --git a/math/sdpara/Makefile b/math/sdpara/Makefile
index c09bfd9643f6..f24f195f8a01 100644
--- a/math/sdpara/Makefile
+++ b/math/sdpara/Makefile
@@ -64,7 +64,6 @@ post-patch:
s|%%BLAS%%|${BLAS}|g ; \
s|%%LAPACK%%|${LAPACK}|g ; \
s|%%SCALAPACK%%|${SCALAPACK}|g ; \
- s|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g ; \
s|%%FORTRAN_LIBS%%|${GCCLIBDIR} ${FORTRAN_LIBS}|g ' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|%%MPICC%%|${LOCALBASE}/bin/mpicc|g ; \
s|%%MPICXX%%|${LOCALBASE}/bin/mpicxx|g ; \
diff --git a/math/sdpara/files/patch-Makefile b/math/sdpara/files/patch-Makefile
index 36bfe61ec64f..4b96fe097d7f 100644
--- a/math/sdpara/files/patch-Makefile
+++ b/math/sdpara/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2009-01-09 02:26:29.000000000 +0000
+--- Makefile.orig 2009-01-09 02:26:29 UTC
+++ Makefile
-@@ -4,20 +4,20 @@
+@@ -4,19 +4,19 @@
# you edit here along your environment
############################################################
@@ -17,7 +17,6 @@
-SCALAPACK_LIBS = /usr/local/scalapack/lib/libscalapack.a /usr/local/BLACS/LIB/blacs_MPI-LINUX-0.a /usr/local/BLACS/LIB/blacsCinit_MPI-LINUX-0.a /usr/local/BLACS/LIB/blacs_MPI-LINUX-0.a
-
-FORTRAN_LIBS = -lgfortran
--PTHERAD_LIBS = -lpthread
+CC = %%MPICC%%
+CXX = %%MPICXX%%
+F77 = %%MPIF77%%
@@ -31,11 +30,10 @@
+SCALAPACK_LIBS = %%SCALAPACK%%
+
+FORTRAN_LIBS = %%FORTRAN_LIBS%%
-+PTHERAD_LIBS = %%PTHREAD_LIBS%%
+ PTHERAD_LIBS = -lpthread
# F77_FUNC
- DEF_F77_FUNC = -DF77_FUNC\(name,NAME\)=name\ \#\#\ _
-@@ -82,10 +82,10 @@ cleanall: clean mumps-clean
+@@ -82,10 +82,10 @@ cleanall: clean mumps-clean
force: cleanall all
mumps: