aboutsummaryrefslogtreecommitdiffstats
path: root/math/spectra
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-05-23 14:44:01 +0800
committeryuri <yuri@FreeBSD.org>2018-05-23 14:44:01 +0800
commitc62ab0a4ad31fb06c27181031b358816d1a44aad (patch)
tree335f672b6f86c960c52ac3f0dd9d7a3c5cf2c893 /math/spectra
parentb68e9dc11f3704f9b89255f26dce94b66f2bbca3 (diff)
downloadfreebsd-ports-gnome-c62ab0a4ad31fb06c27181031b358816d1a44aad.tar.gz
freebsd-ports-gnome-c62ab0a4ad31fb06c27181031b358816d1a44aad.tar.zst
freebsd-ports-gnome-c62ab0a4ad31fb06c27181031b358816d1a44aad.zip
math/spectra: Update 0.6.1 -> 0.6.2
Also add do-test target. Reported by: portscout
Diffstat (limited to 'math/spectra')
-rw-r--r--math/spectra/Makefile7
-rw-r--r--math/spectra/distinfo6
-rw-r--r--math/spectra/files/patch-test_Makefile8
3 files changed, 17 insertions, 4 deletions
diff --git a/math/spectra/Makefile b/math/spectra/Makefile
index 6b95168b22a9..d5e432885f43 100644
--- a/math/spectra/Makefile
+++ b/math/spectra/Makefile
@@ -2,7 +2,7 @@
PORTNAME= spectra
DISTVERSIONPREFIX= v
-DISTVERSION= 0.6.1
+DISTVERSION= 0.6.2
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -16,7 +16,12 @@ GH_ACCOUNT= yixuan
NO_BUILD= yes
NO_ARCH= yes
+TEST_RUN_DEPENDS= gmake>0:devel/gmake
+
do-install:
cd ${WRKSRC} && ${COPYTREE_SHARE} include ${STAGEDIR}${PREFIX}
+do-test: # some tests are known to fail: https://github.com/yixuan/spectra/issues/47
+ @cd ${WRKSRC}/test && ${SETENV} ${MAKE_ENV} CXXFLAGS=-I${LOCALBASE}/include/eigen3 ${GMAKE} all test
+
.include <bsd.port.mk>
diff --git a/math/spectra/distinfo b/math/spectra/distinfo
index 2732bdb33143..6f66f559c031 100644
--- a/math/spectra/distinfo
+++ b/math/spectra/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1524467637
-SHA256 (yixuan-spectra-v0.6.1_GH0.tar.gz) = 8cd78754de89ffa2990576d6fb7832ff5504a0fbd9f3d2ec9bda4993f9a639a1
-SIZE (yixuan-spectra-v0.6.1_GH0.tar.gz) = 164458
+TIMESTAMP = 1527051358
+SHA256 (yixuan-spectra-v0.6.2_GH0.tar.gz) = 28ef6a11707678cd6d678b2006786aa7d1af75773a4e2cacbadcdbe2710190cc
+SIZE (yixuan-spectra-v0.6.2_GH0.tar.gz) = 168066
diff --git a/math/spectra/files/patch-test_Makefile b/math/spectra/files/patch-test_Makefile
new file mode 100644
index 000000000000..7910f59f11e3
--- /dev/null
+++ b/math/spectra/files/patch-test_Makefile
@@ -0,0 +1,8 @@
+--- test/Makefile.orig 2018-05-22 20:39:55 UTC
++++ test/Makefile
+@@ -1,4 +1,4 @@
+-CXXFLAGS = -std=c++11 -Wall -O2 -Wno-parentheses -Wno-misleading-indentation -Wno-int-in-bool-context
++CXXFLAGS += -std=c++11 -Wall -O2 -Wno-parentheses
+ CPPFLAGS = -I../include
+ LDFLAGS =
+ LIBS =