aboutsummaryrefslogtreecommitdiffstats
path: root/math/suitesparse
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2010-02-16 14:00:27 +0800
committermaho <maho@FreeBSD.org>2010-02-16 14:00:27 +0800
commite7742bb9daf387c1002339d81ba355d47c5d07d9 (patch)
treea798bb24ef0b32fec293f75f4ae6f2fb62309d78 /math/suitesparse
parent5b6447e57ae11e62f79b9df35938172fc7732153 (diff)
downloadfreebsd-ports-gnome-e7742bb9daf387c1002339d81ba355d47c5d07d9.tar.gz
freebsd-ports-gnome-e7742bb9daf387c1002339d81ba355d47c5d07d9.tar.zst
freebsd-ports-gnome-e7742bb9daf387c1002339d81ba355d47c5d07d9.zip
Fux build with gotoblas.
PR: 143970 Submitted by: nwhitehorn Feature safe: yes
Diffstat (limited to 'math/suitesparse')
-rw-r--r--math/suitesparse/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/math/suitesparse/Makefile b/math/suitesparse/Makefile
index d47b3fe938ca..705005ff30a7 100644
--- a/math/suitesparse/Makefile
+++ b/math/suitesparse/Makefile
@@ -29,7 +29,7 @@ CONFLICTS= umfpack-*
USE_BLAS?= reference
-.if exists(${LOCALBASE}/lib/libgoto.so)
+.if exists(${LOCALBASE}/lib/libgoto2.so)
USE_BLAS= gotoblas
.elif exists(${LOCALBASE}/lib/libatlas_r.so)
USE_BLAS= atlas
@@ -41,10 +41,10 @@ LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
.elif ${USE_BLAS} == gotoblas
-LIB_DEPENDS+= goto:${PORTSDIR}/math/gotoblas
+LIB_DEPENDS+= goto2:${PORTSDIR}/math/gotoblas
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
-BLAS= -pthread -lgotop
-LAPACK= -pthread -lgotop -llapack
+BLAS= -pthread -lgoto2p
+LAPACK= -pthread -lgoto2p
.elif ${USE_BLAS} == atlas
LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
BLAS= -pthread -lptf77blas -lptcblas -latlas_r