aboutsummaryrefslogtreecommitdiffstats
path: root/math/suitesparse
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2007-01-27 04:36:58 +0800
committerthierry <thierry@FreeBSD.org>2007-01-27 04:36:58 +0800
commita00d99b5ba1ea37b4c58d136f0e5f7438349f81f (patch)
treef5af816e7bba3ccc9463980ffc744d256e77916c /math/suitesparse
parent4f33ea95ca7402e09590f1d761d4b6adc2e6dd0b (diff)
downloadfreebsd-ports-gnome-a00d99b5ba1ea37b4c58d136f0e5f7438349f81f.tar.gz
freebsd-ports-gnome-a00d99b5ba1ea37b4c58d136f0e5f7438349f81f.tar.zst
freebsd-ports-gnome-a00d99b5ba1ea37b4c58d136f0e5f7438349f81f.zip
Fix build if WITH_ATLAS is defined.
Approved by: maho
Diffstat (limited to 'math/suitesparse')
-rw-r--r--math/suitesparse/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/math/suitesparse/Makefile b/math/suitesparse/Makefile
index a076e1c99afa..0b2772db1498 100644
--- a/math/suitesparse/Makefile
+++ b/math/suitesparse/Makefile
@@ -23,11 +23,11 @@ CONFLICTS= umfpack-*
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
-WITH_ATLAS= yes
+WITH_ATLAS= yes
.endif
.if defined(WITH_ATLAS)
LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
-BLAS= -L${LOCALBASE}/lib -lf77blas -latlas
+BLAS= -L${LOCALBASE}/lib -lf77blas -latlas -lcblas
LAPACK= -L${LOCALBASE}/lib -lalapack
.else
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
@@ -42,7 +42,7 @@ FPIC= -fPIC
FPIC= -fpic
.endif
-USE_LDCONFIG= yes
+USE_LDCONFIG= yes
USE_GMAKE= yes
WANT_FORTRAN= yes #dummy but future use
BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42