aboutsummaryrefslogtreecommitdiffstats
path: root/math/superlu
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-01-10 20:56:11 +0800
committermaho <maho@FreeBSD.org>2007-01-10 20:56:11 +0800
commite262eef1021d43cea1f2f2d71c57d01d6efd8d4a (patch)
treefa39d081bc05ecf6ad4080b44e0ade6caafdad96 /math/superlu
parenta70ddd90ac6e3f8dce52681cdf2657d0253428b8 (diff)
downloadfreebsd-ports-gnome-e262eef1021d43cea1f2f2d71c57d01d6efd8d4a.tar.gz
freebsd-ports-gnome-e262eef1021d43cea1f2f2d71c57d01d6efd8d4a.tar.zst
freebsd-ports-gnome-e262eef1021d43cea1f2f2d71c57d01d6efd8d4a.zip
* We can choose (automatically) math/blas or math/atlas
Diffstat (limited to 'math/superlu')
-rw-r--r--math/superlu/Makefile23
1 files changed, 14 insertions, 9 deletions
diff --git a/math/superlu/Makefile b/math/superlu/Makefile
index 7a0c4b00730a..69a0316fef6d 100644
--- a/math/superlu/Makefile
+++ b/math/superlu/Makefile
@@ -20,22 +20,27 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= maho@FreeBSD.org
COMMENT= A library of routines for performing sparse factorization
-.ifdef WITH_ATLAS
-LIB_DEPENDS= atlas:${PORTSDIR}/math/atlas
+.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
+WITH_ATLAS= yes
+.endif
+.if defined(WITH_ATLAS)
+LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
+BLAS= -lf77blas -latlas
+LAPACK= -lalapack
.else
-LIB_DEPENDS= blas.1:${PORTSDIR}/math/blas
+LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
+BLAS= -lblas
+LAPACK= -llapack
.endif
+WANT_FORTRAN=yes
+USE_GCC=4.2+
+
P_VERSION= 3.0
WRKSRC= ${WRKDIR}/SuperLU_${P_VERSION}
ALL_TARGET= superlulib
-.ifdef WITH_ATLAS
-BLAS_LIBS= -lf77blas -latlas
-.else
-BLAS_LIBS?= -lblas
-.endif
-
ARCH2FIX= SRC/Makefile TESTING/MATGEN/Makefile CBLAS/Makefile make.inc \
MAKE_INC/make.alpha MAKE_INC/make.inc