aboutsummaryrefslogtreecommitdiffstats
path: root/math/taucs/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-01-03 18:27:38 +0800
committeredwin <edwin@FreeBSD.org>2004-01-03 18:27:38 +0800
commit5a9962a18ad226b647144a5f4de0264e3b799d75 (patch)
treea0771b552219f15466d92bd875190fc0f031966a /math/taucs/Makefile
parentfcba4614d1e226cb09c18668e807c6f6455115a0 (diff)
downloadfreebsd-ports-gnome-5a9962a18ad226b647144a5f4de0264e3b799d75.tar.gz
freebsd-ports-gnome-5a9962a18ad226b647144a5f4de0264e3b799d75.tar.zst
freebsd-ports-gnome-5a9962a18ad226b647144a5f4de0264e3b799d75.zip
NEW port: math/taucs
TAUCS is a C library of sparse linear solvers. It's very fast and it works well with low memory configurations. PR: ports/55196 Submitted by: Pedro F. Giffuni <giffunip@yahoo.com>
Diffstat (limited to 'math/taucs/Makefile')
-rw-r--r--math/taucs/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/math/taucs/Makefile b/math/taucs/Makefile
new file mode 100644
index 000000000000..8bd82508d8b7
--- /dev/null
+++ b/math/taucs/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: taucs
+# Date created: 5 July 2003
+# Whom: Pedro Giffuni <giffunip@asme.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= taucs
+PORTVERSION= 2.2
+CATEGORIES= math
+MASTER_SITES= http://www.tau.ac.il/~stoledo/taucs/${PORTVERSION}/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= C library of sparse linear solvers
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libf77blas.a:${PORTSDIR}/math/atlas \
+ ${LOCALBASE}/lib/liblapack.a:${PORTSDIR}/math/lapack \
+ ${LOCALBASE}/lib/libmetis.a:${PORTSDIR}/math/metis
+
+NO_WRKSUBDIR= yes
+HAS_CONFIGURE= yes
+MAKEFILE= makefile
+ALL_TARGET=
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/lib/FreeBSD/libtaucs.a ${PREFIX}/lib
+ @${INSTALL_PROGRAM} ${WRKSRC}/bin/FreeBSD/direct ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/bin/FreeBSD/iter ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/*.pdf ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>