aboutsummaryrefslogtreecommitdiffstats
path: root/math/triangle
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2004-11-16 06:51:06 +0800
committerthierry <thierry@FreeBSD.org>2004-11-16 06:51:06 +0800
commit4d715a2a65b3624e5617909e820b7e8be9f4c973 (patch)
tree219a29ff725aa728f11362fc05c167b87b453f41 /math/triangle
parentaf98cf6b3f8f29b677782709e549189021dc69b1 (diff)
downloadfreebsd-ports-gnome-4d715a2a65b3624e5617909e820b7e8be9f4c973.tar.gz
freebsd-ports-gnome-4d715a2a65b3624e5617909e820b7e8be9f4c973.tar.zst
freebsd-ports-gnome-4d715a2a65b3624e5617909e820b7e8be9f4c973.zip
Add triangle 1.5, a Two-Dimensional Quality Mesh Generator and
Delaunay Triangulator. Change category from cad to math. Requested by: Pedro F. Giffuni Approved by: marcus
Diffstat (limited to 'math/triangle')
-rw-r--r--math/triangle/Makefile36
-rw-r--r--math/triangle/distinfo2
-rw-r--r--math/triangle/files/patch-makefile20
-rw-r--r--math/triangle/files/patch-showme.c11
-rw-r--r--math/triangle/pkg-descr11
5 files changed, 80 insertions, 0 deletions
diff --git a/math/triangle/Makefile b/math/triangle/Makefile
new file mode 100644
index 000000000000..e7d4f5a3635f
--- /dev/null
+++ b/math/triangle/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: triangle
+# Date created: 16 Octobre 2004
+# Whom: Thierry Thomas <thierry@pompo.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= triangle
+PORTVERSION= 1.5
+CATEGORIES= math
+MASTER_SITES= http://cm.bell-labs.com/netlib/voronoi/
+DISTNAME= ${PORTNAME}
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A Two-Dimensional Quality Mesh Generator and Delaunay Triangulator
+
+NO_CDROM= Triangle must not be sold for profit
+
+USE_ZIP= yes
+USE_XLIB= yes
+MAKEFILE= makefile
+
+WRKSRC= ${WRKDIR}
+
+PLIST_FILES= bin/triangle bin/showme
+
+do-install:
+ ${INSTALL_PROGRAM} ${PLIST_FILES:S|^bin|${WRKSRC}|} ${PREFIX}/bin
+
+.if defined(MAINTAINER_MODE)
+test: build
+ (cd ${INSTALL_WRKSRC} && ./triangle -p A.poly && ./showme A.1.poly)
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/triangle/distinfo b/math/triangle/distinfo
new file mode 100644
index 000000000000..f46475f032b0
--- /dev/null
+++ b/math/triangle/distinfo
@@ -0,0 +1,2 @@
+MD5 (triangle-1.5/triangle.zip) = b21af03259aba872c32daf923a96aa00
+SIZE (triangle-1.5/triangle.zip) = 157525
diff --git a/math/triangle/files/patch-makefile b/math/triangle/files/patch-makefile
new file mode 100644
index 000000000000..abd4ddd335d2
--- /dev/null
+++ b/math/triangle/files/patch-makefile
@@ -0,0 +1,20 @@
+--- makefile.orig Wed Apr 28 05:13:34 2004
++++ makefile Sat Oct 16 22:54:43 2004
+@@ -18,7 +18,7 @@
+
+ # CC should be set to the name of your favorite C compiler.
+
+-CC = cc
++# CC = cc
+
+ # CSWITCHES is a list of all switches passed to the C compiler. I strongly
+ # recommend using the best level of optimization. I also strongly
+@@ -71,7 +71,7 @@
+ #
+ # CSWITCHES = -O -DNO_TIMER -DLINUX -I/usr/X11R6/include -L/usr/X11R6/lib
+
+-CSWITCHES = -O -DLINUX -I/usr/X11R6/include -L/usr/X11R6/lib
++CSWITCHES = ${CFLAGS} -I${X11BASE}/include -L${X11BASE}/lib
+
+ # TRILIBDEFS is a list of definitions used to compile an object code version
+ # of Triangle (triangle.o) to be called by another program. The file
diff --git a/math/triangle/files/patch-showme.c b/math/triangle/files/patch-showme.c
new file mode 100644
index 000000000000..7d0ee0736a2e
--- /dev/null
+++ b/math/triangle/files/patch-showme.c
@@ -0,0 +1,11 @@
+--- ./showme.c.orig Wed Apr 28 05:13:34 2004
++++ ./showme.c Sat Oct 16 23:00:09 2004
+@@ -106,6 +106,8 @@
+ #include <X11/Xutil.h>
+ #include <X11/Xatom.h>
+
++#include <stdlib.h>
++
+ /* The following obscenity seems to be necessary to ensure that this program */
+ /* will port to Dec Alphas running OSF/1, because their stdio.h file commits */
+ /* the unpardonable sin of including stdlib.h. Hence, malloc(), free(), and */
diff --git a/math/triangle/pkg-descr b/math/triangle/pkg-descr
new file mode 100644
index 000000000000..b6edb5a8d7bc
--- /dev/null
+++ b/math/triangle/pkg-descr
@@ -0,0 +1,11 @@
+Triangle generates exact Delaunay triangulations, constrained Delaunay
+triangulations, Voronoi diagrams, and quality conforming Delaunay
+triangulations. The latter can be generated with no small angles, and
+are thus suitable for finite element analysis.
+
+Show Me graphically displays (using X) the contents of geometric files,
+especially those generated by Triangle, my two-dimensional quality mesh
+generator and Delaunay triangulator.
+Show Me can also write PostScript images to files.
+
+WWW: http://www-2.cs.cmu.edu/~quake/triangle.html