aboutsummaryrefslogtreecommitdiffstats
path: root/math/ump/Makefile
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-02-07 02:25:04 +0800
committermarino <marino@FreeBSD.org>2015-02-07 02:25:04 +0800
commit610fb3ad0cac40ae9ccc73465e3248886bc5e7df (patch)
tree4bcd82284e99583285de0dda0445f18058ad9cb1 /math/ump/Makefile
parent24162e3ad2a341e139af31c140402e2c00dd383d (diff)
downloadfreebsd-ports-gnome-610fb3ad0cac40ae9ccc73465e3248886bc5e7df.tar.gz
freebsd-ports-gnome-610fb3ad0cac40ae9ccc73465e3248886bc5e7df.tar.zst
freebsd-ports-gnome-610fb3ad0cac40ae9ccc73465e3248886bc5e7df.zip
math/ump: Finish original "fix on current"
Back on 10 OCT 2014 when the PR was opened, this unmaintained port didn't build on current. The PR stagnanted due to an unanswered question and the port was eventually fixed by amdmi3 on 21 NOV. Let's go ahead and make the remaining changes which include adding a license (GPLv2), defining desktop entries, tweaking pkg-descr, and make real_frac function match its changed header (for clang). PR: 194497 Submitted by: Ports Fury
Diffstat (limited to 'math/ump/Makefile')
-rw-r--r--math/ump/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/math/ump/Makefile b/math/ump/Makefile
index 72eb42b36d1d..5a90be79020c 100644
--- a/math/ump/Makefile
+++ b/math/ump/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ump
PORTVERSION= 0.8.6
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= math
MASTER_SITES= SF/u-m-p/u-m-p/${PORTVERSION}
PKGNAMESUFFIX= -math
@@ -11,7 +11,7 @@ PKGNAMESUFFIX= -math
MAINTAINER= ports@FreeBSD.org
COMMENT= Graphical, easy to use math program
-CONFLICTS= ump-1.[0-9]*
+LICENSE= GPLv2
USES= gmake pkgconfig tar:bzip2
USE_GNOME= gtk20
@@ -20,15 +20,15 @@ USE_GL= glu
ALL_TARGET= ${PORTNAME}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-MAKE_ENV+= DATADIR="${DATADIR}"
+CONFLICTS= ump-1.[0-9]*
-FIND_DIRS= -type d
-FIND_DATA= -type f
+DESKTOP_ENTRIES="Ump" "" "" "ump" "Education;Math;Science;GTK;" ""
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/src/main.cpp
post-install:
- ${INSTALL_DATA} ${WRKSRC}/ump.conf ${STAGEDIR}${PREFIX}/etc/ump.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/ump.conf \
+ ${STAGEDIR}${PREFIX}/etc/ump.conf.sample
.include <bsd.port.mk>