aboutsummaryrefslogtreecommitdiffstats
path: root/math/unuran
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-06-25 13:35:31 +0800
committerbapt <bapt@FreeBSD.org>2014-06-25 13:35:31 +0800
commit7081e7e5b12afca923788e24924af7212c2bc526 (patch)
tree6379d84ceeca72bc6c80702dd60bd714b378b04a /math/unuran
parentd11d1e4cc7b3c1ec281b2ea35d2fc5d85e4c5102 (diff)
downloadfreebsd-ports-gnome-7081e7e5b12afca923788e24924af7212c2bc526.tar.gz
freebsd-ports-gnome-7081e7e5b12afca923788e24924af7212c2bc526.tar.zst
freebsd-ports-gnome-7081e7e5b12afca923788e24924af7212c2bc526.zip
Convert GMAKE to MAKE_CMD
Please note that lots of invocation of MAKE_CMD here are wrong as they do not properly respect MAKE_ENV and friends With hat: portmgr
Diffstat (limited to 'math/unuran')
-rw-r--r--math/unuran/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/math/unuran/Makefile b/math/unuran/Makefile
index af182a500846..70f9c158ba5c 100644
--- a/math/unuran/Makefile
+++ b/math/unuran/Makefile
@@ -20,14 +20,14 @@ CONFIGURE_ARGS= --enable-shared --with-urng-rngstream --with-urng-default=rngstr
--enable-info
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAKE_ENV= MAKE="${GMAKE}"
+MAKE_ENV= MAKE="${MAKE_CMD}"
USE_LDCONFIG= yes
INFO= unuran
PORTDOCS= unuran.pdf unuran.txt
post-patch:
- ${REINPLACE_CMD} -e '/UNURANFULLCHECK=true make check/s/make/${GMAKE}/' \
+ ${REINPLACE_CMD} -e '/UNURANFULLCHECK=true make check/s/make/${MAKE_CMD}/' \
${WRKSRC}/Makefile.in
.ifndef(NOPORTDOCS)
@@ -42,10 +42,10 @@ post-install:
CONFIGURE_ARGS+= --enable-check-struct --enable-logging
check regression-test test: build
- @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} check)
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} check)
fullcheck: build
- @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} fullcheck)
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} fullcheck)
.endif