aboutsummaryrefslogtreecommitdiffstats
path: root/math/vtk/Makefile
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2000-03-30 16:25:16 +0800
committertg <tg@FreeBSD.org>2000-03-30 16:25:16 +0800
commit93452d824a208b971bd975b7fe2a0fa971c020f5 (patch)
treef123055ef8c0072391ede9218b61e64310dbcca9 /math/vtk/Makefile
parentb52048253b3763084735a59b78102d1f2124b83b (diff)
downloadfreebsd-ports-gnome-93452d824a208b971bd975b7fe2a0fa971c020f5.tar.gz
freebsd-ports-gnome-93452d824a208b971bd975b7fe2a0fa971c020f5.tar.zst
freebsd-ports-gnome-93452d824a208b971bd975b7fe2a0fa971c020f5.zip
Upgrade to 3.1.
PR: 17604 Submitted by: Randall Hopper <aa8vb@ipass.net>
Diffstat (limited to 'math/vtk/Makefile')
-rw-r--r--math/vtk/Makefile33
1 files changed, 27 insertions, 6 deletions
diff --git a/math/vtk/Makefile b/math/vtk/Makefile
index 272dc20a6ddc..12cc8dd0d064 100644
--- a/math/vtk/Makefile
+++ b/math/vtk/Makefile
@@ -1,27 +1,48 @@
# New ports collection makefile for: vtk
-# Version required: 2.3
+# Version required: 3.1
# Date created: 24 Nov 1997
# Whom: Thomas Gellekum <tg@FreeBSD.org>
#
# $FreeBSD$
#
-DISTNAME= vtk23unix
-PKGNAME= vtk-2.3
+DISTNAME= vtk31Unix
+PKGNAME= vtk-3.1
CATEGORIES= math
-MASTER_SITES= ftp://vtk.scorec.rpi.edu/pub/
+MASTER_SITES= ftp://public.kitware.com/pub/vtk/
MAINTAINER= ports@FreeBSD.org
+BUILD_DEPENDS=
LIB_DEPENDS= GL.14:${PORTSDIR}/graphics/Mesa3 \
- tk80.1:${PORTSDIR}/x11-toolkits/tk80
+ tk82.1:${PORTSDIR}/x11-toolkits/tk82
+RUN_DEPENDS=
-WRKSRC= $(WRKDIR)/vtk
+WRKSRC= $(WRKDIR)/vtk31
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-mesa --with-shared --with-tcl --with-bsdmake
+CONFIGURE_ARGS+= --with-contrib --with-tkwidget
CONFIGURE_ENV= CFLAGS="${CFLAGS}" CXXFLAGS="${CFLAGS}"
+# Support for Python is compiled in by default.
+WITH_PYTHON?= yes
+.if defined(WITH_PYTHON) && $(WITH_PYTHON) == yes
+CONFIGURE_ARGS+= --with-python
+BUILD_DEPENDS+= python:${PORTSDIR}/lang/python
+RUN_DEPENDS+= python:${PORTSDIR}/lang/python
+.endif
+
+WITH_PATENTED?= no
+.if defined(WITH_PATENTED) && $(WITH_PATENTED) == yes
+CONFIGURE_ARGS+= --with-patented
+PLIST= ${PKGDIR}/PLIST.with_patented
+.endif
+
post-install:
+.if defined(WITH_PYTHON) && $(WITH_PYTHON) == yes
+ ${PREFIX}/bin/python -c "import compileall; compileall.compile_dir( '${PREFIX}/lib/vtk/python' );"
+ ${PREFIX}/bin/python -Oc "import compileall; compileall.compile_dir( '${PREFIX}/lib/vtk/python' );"
+.endif
${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.mk>