aboutsummaryrefslogtreecommitdiffstats
path: root/math/vtk43
diff options
context:
space:
mode:
authorreg <reg@FreeBSD.org>2000-04-17 08:19:02 +0800
committerreg <reg@FreeBSD.org>2000-04-17 08:19:02 +0800
commitd22cbcc0186bfcde72d3058c3d06d1032bb7157e (patch)
treeefb5227e2fc359da16edf2ca8a5ca4744a25bc3e /math/vtk43
parent8b766534122d71052c9f8e5a0752944edf0450f8 (diff)
downloadfreebsd-ports-gnome-d22cbcc0186bfcde72d3058c3d06d1032bb7157e.tar.gz
freebsd-ports-gnome-d22cbcc0186bfcde72d3058c3d06d1032bb7157e.tar.zst
freebsd-ports-gnome-d22cbcc0186bfcde72d3058c3d06d1032bb7157e.zip
Standardize all user defined options to the booleans WITH_FOO and
WITHOUT_FOO. Begin the process of reserving these prefixes for user defined options. No comment by: ports
Diffstat (limited to 'math/vtk43')
-rw-r--r--math/vtk43/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/math/vtk43/Makefile b/math/vtk43/Makefile
index e5dc22545d37..0f97c57db41b 100644
--- a/math/vtk43/Makefile
+++ b/math/vtk43/Makefile
@@ -22,24 +22,21 @@ WRKSRC= $(WRKDIR)/vtk31
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-mesa --with-shared --with-tcl --with-bsdmake
CONFIGURE_ARGS+= --with-contrib --with-tkwidget
-CONFIGURE_ENV= CFLAGS="${CFLAGS}" CXXFLAGS="${CFLAGS}"
# Support for Python is compiled in by default.
-WITH_PYTHON?= yes
-.if defined(WITH_PYTHON) && $(WITH_PYTHON) == yes
+.if !defined(WITHOUT_PYTHON)
CONFIGURE_ARGS+= --with-python
BUILD_DEPENDS+= python:${PORTSDIR}/lang/python
RUN_DEPENDS+= python:${PORTSDIR}/lang/python
.endif
-WITH_PATENTED?= no
-.if defined(WITH_PATENTED) && $(WITH_PATENTED) == yes
+.if defined(WITH_PATENTED)
CONFIGURE_ARGS+= --with-patented
PLIST= ${PKGDIR}/PLIST.with_patented
.endif
post-install:
-.if defined(WITH_PYTHON) && $(WITH_PYTHON) == yes
+.if !defined(WITHOUT_PYTHON)
${PREFIX}/bin/python -c "import compileall; compileall.compile_dir( '${PREFIX}/lib/vtk/python' );"
${PREFIX}/bin/python -Oc "import compileall; compileall.compile_dir( '${PREFIX}/lib/vtk/python' );"
.endif