aboutsummaryrefslogtreecommitdiffstats
path: root/math/vtk5
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2009-08-08 01:04:10 +0800
committerthierry <thierry@FreeBSD.org>2009-08-08 01:04:10 +0800
commitddc036fa97fd6b98444bdcf9789f18cb698807fc (patch)
tree70a6611e3f33eaa34fb9a659d180ec3af11f0f4c /math/vtk5
parentacb5a17da44a10adb05ca16436eec85d5dfdc496 (diff)
downloadfreebsd-ports-gnome-ddc036fa97fd6b98444bdcf9789f18cb698807fc.tar.gz
freebsd-ports-gnome-ddc036fa97fd6b98444bdcf9789f18cb698807fc.tar.zst
freebsd-ports-gnome-ddc036fa97fd6b98444bdcf9789f18cb698807fc.zip
Add GL2PS knobs to OPTIONS, and default to it.
This knobs need to build Salome application: http://www.salome-platform.org/ex/att/16_SALOME_4_1_5_Release_Notes.pdf, page 14 PR: ports/137162 Submitted by: Stas Timokhin <stast (at) bsdportal.ru>
Diffstat (limited to 'math/vtk5')
-rw-r--r--math/vtk5/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/math/vtk5/Makefile b/math/vtk5/Makefile
index 65a30a5a2c0a..9d8574d39ec3 100644
--- a/math/vtk5/Makefile
+++ b/math/vtk5/Makefile
@@ -8,7 +8,7 @@
PORTNAME= vtk
PORTVERSION= 5.0.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= math graphics
MASTER_SITES= http://www.vtk.org/files/release/${PORTVERSION:R}/ \
http://www.neuro.mcw.edu/Ports/distfiles/VTK5/
@@ -50,7 +50,8 @@ USE_GL= yes
USE_LDCONFIG= yes
OPTIONS= MANGLEDMESA "Use off-screen (Mangled) Mesa" Off \
- VTKMPEG2 "Install patented MPEG2 encoder module" Off
+ VTKMPEG2 "Install patented MPEG2 encoder module" Off \
+ GL2PS "Install support conversion OpenGL to PostScript" On
PLIST_SUB= VER=${PORTVERSION} VER1=${PORTVERSION:R} VER2=${PORTVERSION:R:R}
@@ -107,6 +108,12 @@ CMAKE_ARGS+= -DvtkMPEG2Encode_INCLUDE_PATH=${LOCALBASE}/include/vtk-5.0 \
-DVTK_USE_MPEG2_ENCODER:BOOL=ON
.endif
+.if defined(WITH_GL2PS)
+LIB_DEPENDS+= gl2ps.1:${PORTSDIR}/print/gl2ps
+CMAKE_ARGS+= -DVTK_USE_GL2PS:BOOL=ON
+PLIST_FILES+= include/vtk-5.0/vtkGL2PSExporter.h
+.endif
+
post-extract:
${MKDIR} ${WRKSRC}
${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|g' \