aboutsummaryrefslogtreecommitdiffstats
path: root/math/vtk6/files
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2015-11-28 09:59:35 +0800
committerstephen <stephen@FreeBSD.org>2015-11-28 09:59:35 +0800
commit38085a0968d7d46ca9fa7a1d6694fdae7896a8db (patch)
tree08bfbb03e3af12cce5fcce8c03db5d77b8fe865c /math/vtk6/files
parente09d4ce880bd579043d36a52d39d43fd71745267 (diff)
downloadfreebsd-ports-gnome-38085a0968d7d46ca9fa7a1d6694fdae7896a8db.tar.gz
freebsd-ports-gnome-38085a0968d7d46ca9fa7a1d6694fdae7896a8db.tar.zst
freebsd-ports-gnome-38085a0968d7d46ca9fa7a1d6694fdae7896a8db.zip
- Update to 6.2.0.
Diffstat (limited to 'math/vtk6/files')
-rw-r--r--math/vtk6/files/patch-GUISupport-Qt_CMakeLists.txt12
-rw-r--r--math/vtk6/files/patch-Rendering-FreeType_vtkFreeTypeTools.cxx28
-rw-r--r--math/vtk6/files/patch-Rendering_OpenGL_vtkXOpenGLRenderWindow.cxx22
-rw-r--r--math/vtk6/files/patch-Wrapping-Tcl_CMakeLists.txt8
4 files changed, 10 insertions, 60 deletions
diff --git a/math/vtk6/files/patch-GUISupport-Qt_CMakeLists.txt b/math/vtk6/files/patch-GUISupport-Qt_CMakeLists.txt
index ced5f2266128..3260c4238e1b 100644
--- a/math/vtk6/files/patch-GUISupport-Qt_CMakeLists.txt
+++ b/math/vtk6/files/patch-GUISupport-Qt_CMakeLists.txt
@@ -1,6 +1,6 @@
---- GUISupport/Qt/CMakeLists.txt.orig 2014-01-22 16:55:41.000000000 +0100
-+++ GUISupport/Qt/CMakeLists.txt 2014-03-10 12:25:40.000000000 +0100
-@@ -101,7 +101,7 @@
+--- GUISupport/Qt/CMakeLists.txt.orig 2015-03-03 14:37:14.000000000 -0600
++++ GUISupport/Qt/CMakeLists.txt 2015-11-25 17:08:37.840001000 -0600
+@@ -104,7 +104,7 @@
endif()
# This build plugin logic should just get migrated into a module I think.
@@ -9,7 +9,7 @@
set(PluginLibSrcs Q4VTKWidgetPlugin.cxx)
set(PluginMocHeaders Q4VTKWidgetPlugin.h)
-@@ -121,16 +121,16 @@
+@@ -124,16 +124,16 @@
# add QVTK plugin from sources
# stand-alone as it doesn't depend on QVTK library
@@ -24,8 +24,8 @@
+ set_target_properties(QVTKWidgetPlugin-${VTK_MAJOR_VERSION}.${VTK_MINOR_VERSION} PROPERTIES COMPILE_DEFINITIONS QT_NO_DEBUG)
# link with Qt libs
-- target_link_libraries(QVTKWidgetPlugin ${QT_LIBRARIES})
-+ target_link_libraries(QVTKWidgetPlugin-${VTK_MAJOR_VERSION}.${VTK_MINOR_VERSION} ${QT_LIBRARIES})
+- vtk_module_link_libraries(QVTKWidgetPlugin ${QT_LIBRARIES})
++ vtk_module_link_libraries(QVTKWidgetPlugin-${VTK_MAJOR_VERSION}.${VTK_MINOR_VERSION} ${QT_LIBRARIES})
# install rules
diff --git a/math/vtk6/files/patch-Rendering-FreeType_vtkFreeTypeTools.cxx b/math/vtk6/files/patch-Rendering-FreeType_vtkFreeTypeTools.cxx
deleted file mode 100644
index a6177c9a6f8e..000000000000
--- a/math/vtk6/files/patch-Rendering-FreeType_vtkFreeTypeTools.cxx
+++ /dev/null
@@ -1,28 +0,0 @@
---- Rendering/FreeType/vtkFreeTypeTools.cxx.orig 2015-01-02 17:05:19.000000000 +0000
-+++ Rendering/FreeType/vtkFreeTypeTools.cxx 2015-01-02 17:05:26.000000000 +0000
-@@ -1185,8 +1185,8 @@
- bitmapGlyph);
- if (bitmap)
- {
-- metaData.ascent = std::max(bitmapGlyph->top - 1, metaData.ascent);
-- metaData.descent = std::min(-(bitmap->rows - (bitmapGlyph->top - 1)),
-+ metaData.ascent = std::max<int>(bitmapGlyph->top - 1, metaData.ascent);
-+ metaData.descent = std::min<int>(-(bitmap->rows - (bitmapGlyph->top - 1)),
- metaData.descent);
- }
- ++heightString;
-@@ -1950,10 +1950,10 @@
- fontSize, gindex, bitmapGlyph);
- if (bitmap)
- {
-- bbox[0] = std::min(bbox[0], pen[0] + bitmapGlyph->left);
-- bbox[1] = std::max(bbox[1], pen[0] + bitmapGlyph->left + bitmap->width);
-- bbox[2] = std::min(bbox[2], pen[1] + bitmapGlyph->top - 1 - bitmap->rows);
-- bbox[3] = std::max(bbox[3], pen[1] + bitmapGlyph->top - 1);
-+ bbox[0] = std::min<int>(bbox[0], pen[0] + bitmapGlyph->left);
-+ bbox[1] = std::max<int>(bbox[1], pen[0] + bitmapGlyph->left + bitmap->width);
-+ bbox[2] = std::min<int>(bbox[2], pen[1] + bitmapGlyph->top - 1 - bitmap->rows);
-+ bbox[3] = std::max<int>(bbox[3], pen[1] + bitmapGlyph->top - 1);
- }
- else
- {
diff --git a/math/vtk6/files/patch-Rendering_OpenGL_vtkXOpenGLRenderWindow.cxx b/math/vtk6/files/patch-Rendering_OpenGL_vtkXOpenGLRenderWindow.cxx
deleted file mode 100644
index bd867efdca2e..000000000000
--- a/math/vtk6/files/patch-Rendering_OpenGL_vtkXOpenGLRenderWindow.cxx
+++ /dev/null
@@ -1,22 +0,0 @@
-From 800282f289e3ebeb2873f7914ed560282b482448 Mon Sep 17 00:00:00 2001
-From: "Marcus D. Hanwell" <marcus.hanwell@kitware.com>
-Date: Tue, 9 Sep 2014 13:39:13 -0400
-Subject: [PATCH] Actually define GLX_GLXEXT_LEGACY to prevent the include
-
-Change-Id: I394afaf8a550f5c7b06ceca0898c316e5f2568c9
-
---- Rendering/OpenGL/vtkXOpenGLRenderWindow.cxx.orig 2014-01-22 15:55:41 UTC
-+++ Rendering/OpenGL/vtkXOpenGLRenderWindow.cxx
-@@ -25,9 +25,9 @@
-
- #include "vtkOpenGL.h"
-
--// define GLX_GLXEXT_LEGACY to prevent glx.h to include glxext.h provided by
--// the system
--//#define GLX_GLXEXT_LEGACY
-+// Define GLX_GLXEXT_LEGACY to prevent glx.h from including the glxext.h
-+// provided by the system.
-+#define GLX_GLXEXT_LEGACY
- #include "GL/glx.h"
-
- #include "vtkgl.h"
diff --git a/math/vtk6/files/patch-Wrapping-Tcl_CMakeLists.txt b/math/vtk6/files/patch-Wrapping-Tcl_CMakeLists.txt
index 6d58e9907f83..5fb67beb4844 100644
--- a/math/vtk6/files/patch-Wrapping-Tcl_CMakeLists.txt
+++ b/math/vtk6/files/patch-Wrapping-Tcl_CMakeLists.txt
@@ -1,11 +1,11 @@
---- Wrapping/Tcl/CMakeLists.txt.orig 2014-03-14 09:26:03.000000000 +0100
-+++ Wrapping/Tcl/CMakeLists.txt 2014-03-14 09:26:27.000000000 +0100
-@@ -261,7 +261,7 @@
+--- Wrapping/Tcl/CMakeLists.txt.orig 2015-03-03 14:37:14.000000000 -0600
++++ Wrapping/Tcl/CMakeLists.txt 2015-11-25 17:33:43.838696000 -0600
+@@ -264,7 +264,7 @@
# Configure the Tcl package index file for the install tree.
SET(VTK_TCL_SCRIPT_DIR "[file dirname [info script]]")
IF(UNIX)
- SET(VTK_TCL_LIBRARY_DIR "[file dirname [file dirname [file dirname [info script]]]]")
+ SET(VTK_TCL_LIBRARY_DIR "[file dirname [info script]]")
- ELSE(UNIX)
+ ELSE()
SET(VTK_TCL_LIBRARY_DIR
"[file join [file dirname [file dirname [file dirname [file dirname [info script]]]]] bin]")