aboutsummaryrefslogtreecommitdiffstats
path: root/math/vtk6
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2014-07-01 22:21:27 +0800
committergahr <gahr@FreeBSD.org>2014-07-01 22:21:27 +0800
commitff33cd40c512afcf4bbd0e089923017a8476193d (patch)
tree4aeac8c03f2e08e3998a22fec992a578058dc3e1 /math/vtk6
parentae9c881a82ade8b1af0679899323e5c30a79dfc2 (diff)
downloadfreebsd-ports-gnome-ff33cd40c512afcf4bbd0e089923017a8476193d.tar.gz
freebsd-ports-gnome-ff33cd40c512afcf4bbd0e089923017a8476193d.tar.zst
freebsd-ports-gnome-ff33cd40c512afcf4bbd0e089923017a8476193d.zip
- Add OPTIONal off-screen rendering support with graphics/libosmesa
Diffstat (limited to 'math/vtk6')
-rw-r--r--math/vtk6/Makefile17
-rw-r--r--math/vtk6/pkg-plist5
2 files changed, 17 insertions, 5 deletions
diff --git a/math/vtk6/Makefile b/math/vtk6/Makefile
index 23b3b4805eaa..9a9f81de8bcc 100644
--- a/math/vtk6/Makefile
+++ b/math/vtk6/Makefile
@@ -46,12 +46,13 @@ VTK_WRAPS= JAVA TCLTK # PYTHON
OPTIONS_GROUP= Groups Wrapping
OPTIONS_GROUP_Groups=${VTK_GROUPS}
OPTIONS_GROUP_Wrapping=${VTK_WRAPS}
-OPTIONS_DEFINE= DESIGNER DOCS
+OPTIONS_DEFINE= DESIGNER DOCS OSMESA
OPTIONS_RADIO= Qt
OPTIONS_RADIO_Qt= QT4 QT5
Qt_DESC= Qt GUI support
QT4_DESC= Qt 4 toolkit support
QT5_DESC= Qt 5 toolkit support
+OSMESA_DESC= Use Mesa for off-screen rendering
#OPTIONS_DEFAULT=MPI Qt JAVA PYTHON TCLTK DESIGNER
.for g in ${VTK_GROUPS}
@@ -87,8 +88,18 @@ CMAKE_ARGS+= -DVTK_Group_${g}:BOOL=OFF
. endif
.endfor
-.if ${PORT_OPTIONS:MDOCS}
-CMAKE_ARGS+= -DBUILD_DOCUMENTATION:BOOL=ON
+.if ${PORT_OPTIONS:MOSMESA}
+LIB_DEPENDS+= libOSMesa.so:${PORTSDIR}/graphics/libosmesa
+CMAKE_ARGS+= -DVTK_OPENGL_HAS_OSMESA:BOOL=ON \
+ -DOSMESA_INCLUDE_DIR:PATH=${LOCALBASE}/include/Mesa \
+ -DOSMESA_LIBRARY:FILEPATH=${LOCALBASE}/lib/libOSMesa.so \
+ -DOPENGL_gl_LIBRARY:FILEPATH=${LOCALBASE}/lib/libOSMesa.so \
+ -DVTK_USE_X:BOOL=OFF
+PLIST_SUB+= X11="@comment " \
+ OSMESA=""
+.else
+PLIST_SUB+= X11="" \
+ OSMESA="@comment "
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
diff --git a/math/vtk6/pkg-plist b/math/vtk6/pkg-plist
index b9df9e2f4806..6cf123824f45 100644
--- a/math/vtk6/pkg-plist
+++ b/math/vtk6/pkg-plist
@@ -2157,8 +2157,9 @@ include/vtk-%%VER2%%/vtkXMLUnstructuredGridWriter.h
include/vtk-%%VER2%%/vtkXMLUtilities.h
include/vtk-%%VER2%%/vtkXMLWriter.h
include/vtk-%%VER2%%/vtkXMLWriterC.h
-include/vtk-%%VER2%%/vtkXOpenGLRenderWindow.h
-include/vtk-%%VER2%%/vtkXRenderWindowInteractor.h
+%%X11%%include/vtk-%%VER2%%/vtkXOpenGLRenderWindow.h
+%%X11%%include/vtk-%%VER2%%/vtkXRenderWindowInteractor.h
+%%OSMESA%%include/vtk-%%VER2%%/vtkOSOpenGLRenderWindow.h
include/vtk-%%VER2%%/vtkXYPlotActor.h
include/vtk-%%VER2%%/vtkXYPlotWidget.h
include/vtk-%%VER2%%/vtkXYZMolReader.h