aboutsummaryrefslogtreecommitdiffstats
path: root/math/wxMaxima/files
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2017-07-23 04:41:06 +0800
committernivit <nivit@FreeBSD.org>2017-07-23 04:41:06 +0800
commit688db196322d39db83dcd532082778d50b22b209 (patch)
treedd7b026e21340995545280ab3f83a6c9105e48f4 /math/wxMaxima/files
parent8fa85c744abb2617016bea9e0e3591409eb184cf (diff)
downloadfreebsd-ports-gnome-688db196322d39db83dcd532082778d50b22b209.tar.gz
freebsd-ports-gnome-688db196322d39db83dcd532082778d50b22b209.tar.zst
freebsd-ports-gnome-688db196322d39db83dcd532082778d50b22b209.zip
- Update to 17.05.0
- Fix paths for man page, DOCSDIR and locales via patches - Use CMake instead of GNU configure to build the port - Remove patch/patch-data_Makefile.am ChangeLog: https://github.com/andrejv/wxmaxima/releases/tag/Version-17.05.0
Diffstat (limited to 'math/wxMaxima/files')
-rw-r--r--math/wxMaxima/files/patch-data_CMakeLists.txt11
-rw-r--r--math/wxMaxima/files/patch-data_Makefile.am11
-rw-r--r--math/wxMaxima/files/patch-info_CMakeLists.txt19
-rw-r--r--math/wxMaxima/files/patch-locales_CMakeLists.txt11
4 files changed, 41 insertions, 11 deletions
diff --git a/math/wxMaxima/files/patch-data_CMakeLists.txt b/math/wxMaxima/files/patch-data_CMakeLists.txt
new file mode 100644
index 000000000000..fa9e7dfd47a5
--- /dev/null
+++ b/math/wxMaxima/files/patch-data_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- data/CMakeLists.txt.orig 2017-07-22 20:21:47 UTC
++++ data/CMakeLists.txt
+@@ -26,7 +26,7 @@ else()
+ install(FILES ${DATAFILES} DESTINATION share/wxMaxima)
+ install(FILES ${PIXMAPS} DESTINATION share/pixmaps)
+ install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/wxmaxima DESTINATION share/bash-completion/completions)
+- install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/wxmaxima.1 DESTINATION share/man/man1)
++ install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/wxmaxima.1 DESTINATION man/man1)
+ install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/wxMaxima.appdata.xml DESTINATION share/appdata)
+ install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/wxMaxima.desktop DESTINATION share/applications)
+ install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/x-wxmathml.xml DESTINATION share/mime/packages)
diff --git a/math/wxMaxima/files/patch-data_Makefile.am b/math/wxMaxima/files/patch-data_Makefile.am
deleted file mode 100644
index 173a8ac3d0de..000000000000
--- a/math/wxMaxima/files/patch-data_Makefile.am
+++ /dev/null
@@ -1,11 +0,0 @@
---- data/Makefile.am.orig 2016-04-23 16:57:50 UTC
-+++ data/Makefile.am
-@@ -13,7 +13,7 @@ appicondir = $(datarootdir)/pixmaps
- dist_appicon_DATA = wxmaxima.svg wxmaxima.png text-x-wxmaxima-batch.svg text-x-wxmathml.svg wxmaxima-16.xpm wxmaxima-32.xpm
-
-
--mandatadir = $(datadir)/man/man1
-+mandatadir = $(mandir)/man1
- dist_mandata_DATA = wxmaxima.1
-
- mimedatadir = $(datarootdir)/mime/packages
diff --git a/math/wxMaxima/files/patch-info_CMakeLists.txt b/math/wxMaxima/files/patch-info_CMakeLists.txt
new file mode 100644
index 000000000000..18fbbdd8cbf8
--- /dev/null
+++ b/math/wxMaxima/files/patch-info_CMakeLists.txt
@@ -0,0 +1,19 @@
+--- info/CMakeLists.txt.orig 2017-05-23 18:48:40 UTC
++++ info/CMakeLists.txt
+@@ -6,7 +6,7 @@ file(GLOB IMAGE_FILES *.jpg *.png)
+ if(WIN32)
+ install(FILES wxmaxima.html DESTINATION wxMaxima/help)
+ else()
+- install(FILES wxmaxima.html DESTINATION share/doc/wxmaxima)
++ install(FILES wxmaxima.html DESTINATION share/doc/wxMaxima)
+ endif()
+ #else()
+ # message(STATUS "Makeinfo found at ${MAKEINFO}")
+@@ -31,5 +31,5 @@ endif()
+ if(WIN32)
+ install(FILES ${IMAGE_FILES} DESTINATION wxMaxima/help)
+ else()
+- install(FILES ${IMAGE_FILES} DESTINATION share/doc/wxmaxima)
++ install(FILES ${IMAGE_FILES} DESTINATION share/doc/wxMaxima)
+ endif()
+\ No newline at end of file
diff --git a/math/wxMaxima/files/patch-locales_CMakeLists.txt b/math/wxMaxima/files/patch-locales_CMakeLists.txt
new file mode 100644
index 000000000000..27adcfa67028
--- /dev/null
+++ b/math/wxMaxima/files/patch-locales_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- locales/CMakeLists.txt.orig 2017-07-22 20:15:52 UTC
++++ locales/CMakeLists.txt
+@@ -12,7 +12,7 @@ if(GETTEXT_FOUND)
+ RENAME "wxMaxima.mo")
+ else()
+ install(FILES "${CMAKE_CURRENT_BINARY_DIR}/${LANG}.gmo"
+- DESTINATION "share/wxMaxima/locale/${LANG}/"
++ DESTINATION "share/locale/${LANG}/LC_MESSAGES/"
+ RENAME "wxMaxima.mo")
+ endif()
+ endforeach()