aboutsummaryrefslogtreecommitdiffstats
path: root/math/xplot/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1997-03-06 09:23:08 +0800
committerasami <asami@FreeBSD.org>1997-03-06 09:23:08 +0800
commit7125f4c5465b46fa5c7bef59af595a83fbc529db (patch)
tree1170384ddc147d5baa08a2c9d7b2940bafcd86cd /math/xplot/Makefile
parentac47612ffef6d8367200d880c01df7e93d082a65 (diff)
downloadfreebsd-ports-gnome-7125f4c5465b46fa5c7bef59af595a83fbc529db.tar.gz
freebsd-ports-gnome-7125f4c5465b46fa5c7bef59af595a83fbc529db.tar.zst
freebsd-ports-gnome-7125f4c5465b46fa5c7bef59af595a83fbc529db.zip
Another plotting utility. Commonly used to plot TCP traces.
Submitted by: fenner (he had to leave so I'm importing it)
Diffstat (limited to 'math/xplot/Makefile')
-rw-r--r--math/xplot/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/math/xplot/Makefile b/math/xplot/Makefile
new file mode 100644
index 000000000000..acb4731837a9
--- /dev/null
+++ b/math/xplot/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: xplot
+# Version required: 0.89
+# Date created: 3 March 1997
+# Whom: fenner
+#
+# $Id$
+#
+
+DISTNAME= xplot-0.89
+CATEGORIES= math graphics net
+MASTER_SITES= ftp://mercury.lcs.mit.edu/pub/shep/
+
+MAINTAINER= fenner@FreeBSD.ORG
+
+USE_X11= yes
+GNU_CONFIGURE= yes
+
+XPLOT_DEMOS= demo.0 demo.1 demo.2 demo.3 demo.4 demo.5 demo.6 demo.7
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/tcpdump2xplot.pl ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/xplot
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/xplot
+ ${INSTALL_DATA} ${WRKSRC}/README.tcp_plots ${PREFIX}/share/doc/xplot
+.endif
+ ${MKDIR} ${PREFIX}/share/examples/xplot
+.for i in ${XPLOT_DEMOS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/share/examples/xplot
+.endfor
+
+.include <bsd.port.mk>