aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authortruckman <truckman@FreeBSD.org>2012-06-03 08:59:41 +0800
committertruckman <truckman@FreeBSD.org>2012-06-03 08:59:41 +0800
commit1a5d537ae21b97c269da66aaf17098fb673c312f (patch)
tree9298a95ea15f67f458f9e957ffd6e9d6c4cb68c6 /math
parent0ba1dd0e1b6f6b360954b0364a94212030e2a3c6 (diff)
downloadfreebsd-ports-gnome-1a5d537ae21b97c269da66aaf17098fb673c312f.tar.gz
freebsd-ports-gnome-1a5d537ae21b97c269da66aaf17098fb673c312f.tar.zst
freebsd-ports-gnome-1a5d537ae21b97c269da66aaf17098fb673c312f.zip
Extract saxon.jar from the distfile for the textproc/saxon port into
the thirdparty build directory for the scilab port. This allows the removal of the textproc/saxon build dependency from the scilab port so that scilab can be built on a host that has apache-openoffice-3.4.* installed. The latter port has a run dependency on textproc/saxon-devel, which conflicts with textproc/saxon. PR: 168398 Approved by: Rob Farmer <rfarmer AT predatorlabs.net> (maintainer)
Diffstat (limited to 'math')
-rw-r--r--math/scilab/Makefile13
-rw-r--r--math/scilab/distinfo2
2 files changed, 11 insertions, 4 deletions
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index 73c158293421..ac93bc31627f 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -11,13 +11,18 @@ PORTREVISION= 4
CATEGORIES= math cad parallel java
MASTER_SITES= http://www.scilab.org/download/${PORTVERSION}/:scilab \
http://www.predatorlabs.net/dl/:jgraphx \
- http://www.bayofrum.net/dist/jgraphx/:jgraphx
+ http://www.bayofrum.net/dist/jgraphx/:jgraphx \
+ SF/saxon/saxon6/${SAXON_VERSION}:saxon
DISTFILES= ${DISTNAME}-src.tar.gz:scilab
EXTRACT_ONLY= ${DISTNAME}-src.tar.gz
MAINTAINER= rfarmer@predatorlabs.net
COMMENT= Scientific software package for numerical computations
+SAXON_VERSION= 6.5.5
+SAXON_DISTFILE= saxon${SAXON_VERSION:S/./-/g}.zip
+DISTFILES+= ${SAXON_DISTFILE}:saxon
+
# A partial dependencies list can be found at:
# http://wiki.scilab.org/Dependencies_of_Scilab_5.X
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
@@ -119,8 +124,7 @@ GUI_DEPENDS= ${JAVALIBDIR}/flexdock.jar:${PORTSDIR}/devel/flexdock \
# Can't use USE_ANT because it overrides do-build target
BUILD_DEPENDS+= ${GUI_DEPENDS} \
ant:${PORTSDIR}/devel/apache-ant \
- swig:${PORTSDIR}/devel/swig13 \
- ${LOCALBASE}/share/examples/saxon/data/books.dtd:${PORTSDIR}/textproc/saxon
+ swig:${PORTSDIR}/devel/swig13
RUN_DEPENDS+= ${GUI_DEPENDS}
@@ -213,6 +217,8 @@ post-patch:
@# Run fixes
@${REINPLACE_CMD} -e 's|%%JAVALIBDIR%%|${JAVALIBDIR}|' ${WRKSRC}/etc/librarypath.xml
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/etc/librarypath.xml
+ @${MKDIR} ${WRKSRC}/thirdparty
+ @${UNZIP_CMD} ${DISTDIR}/${SAXON_DISTFILE} saxon.jar -d ${WRKSRC}/thirdparty
.if !defined(WITHOUT_GUI)
@# Configure fixes
@${REINPLACE_CMD} -e 's|/usr/lib/java|${JAVALIBDIR}|g' ${WRKSRC}/configure
@@ -222,7 +228,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|$$jardir/jeuclid-core*.jar|${LOCALBASE}/share/java/jeuclid/repo/jeuclid-core*.jar|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|jrosetta-API.jar|jrosetta-api.jar|' \
${WRKSRC}/configure
- @${MKDIR} ${WRKSRC}/thirdparty
@${CP} ${DISTDIR}/${JGRAPHX_JAR} ${WRKSRC}/thirdparty/jgraphx.jar
@# Run fixes
@${REINPLACE_CMD} -e 's|%%JAVALIBDIR%%|${JAVALIBDIR}|' ${WRKSRC}/etc/librarypath.xml
diff --git a/math/scilab/distinfo b/math/scilab/distinfo
index cc2d62debd11..518da5768464 100644
--- a/math/scilab/distinfo
+++ b/math/scilab/distinfo
@@ -2,3 +2,5 @@ SHA256 (scilab-5.3.3-src.tar.gz) = e6edd7d241f2a09bd2dadaaafff5c152509db24022093
SIZE (scilab-5.3.3-src.tar.gz) = 47253497
SHA256 (jgraphx-1_4_1_0.jar) = 8c4bd7e63a5149b67373857c2cc3d45015463a9075d7b6f078d7307f6d1038ec
SIZE (jgraphx-1_4_1_0.jar) = 503319
+SHA256 (saxon6-5-5.zip) = a76806dda554edc844601d0ec0fb3d2a10a2f397eabf3569dfb44b628363afc4
+SIZE (saxon6-5-5.zip) = 3346162