aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2007-04-14 14:58:38 +0800
committerglewis <glewis@FreeBSD.org>2007-04-14 14:58:38 +0800
commit2801b1ad90966c1b05e037749dc126bdf9177355 (patch)
treedf4b31d93c50f802864a94a530a3c1a5ab7242d7 /math
parent0706272e5687382a50e088ad7b3bc7e54a63e415 (diff)
downloadfreebsd-ports-gnome-2801b1ad90966c1b05e037749dc126bdf9177355.tar.gz
freebsd-ports-gnome-2801b1ad90966c1b05e037749dc126bdf9177355.tar.zst
freebsd-ports-gnome-2801b1ad90966c1b05e037749dc126bdf9177355.zip
. Optional WX support. I don't have it installed, so this is untested.
Reports welcome. Based on the changes in the PR, but tweaked based on the WX section in the Porter's handbook. PR: 111548 Submitted by: bf<bf2006a@yahoo.com>
Diffstat (limited to 'math')
-rw-r--r--math/gnuplot/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index 8f6402be63a5..02f9a24b5dbc 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnuplot
PORTVERSION= 4.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,6 +16,7 @@ MAINTAINER= glewis@FreeBSD.org
COMMENT= A command-driven interactive function plotting program
GNU_CONFIGURE= yes
+WANT_WX= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-kpsexpand \
--with-lasergnu \
@@ -28,7 +29,8 @@ BUILD_DEPENDS+=latex:${PORTSDIR}/print/teTeX-base
OPTIONS= GD "Enable GD support" on \
PDF "Enable PDF support" on \
- PLOT "Enable plot support" on
+ PLOT "Enable plot support" on \
+ WX "Enable WX support" off
MAN1= gnuplot.1 lasergnu.1
INFO= gnuplot
@@ -64,6 +66,14 @@ LIB_DEPENDS+= plot.4:${PORTSDIR}/graphics/plotutils
CONFIGURE_ARGS+= --with-plot=${LOCALBASE}
.endif
+.if defined(WITHOUT_WX)
+CONFIGURE_ARGS+= --disable-wxwidgets
+.else
+USE_WX= 2.4+
+WX_COMPS= wx
+CONFIGURE_ARGS+= --with-wx-config=${WXCONFIG}
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|)/@PACKAGE@/@PKG_MAJOR@|)|g' ${WRKSRC}/src/Makefile.in