aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2006-11-03 02:21:57 +0800
committerglewis <glewis@FreeBSD.org>2006-11-03 02:21:57 +0800
commit3313f96c964f3b94b275ff22a0f8c04865a4e66a (patch)
tree18e25c5def9cd690845c794d983bbc39a4752379 /math
parentee1d2d869d391c39b1666851c50752ddaeffc158 (diff)
downloadfreebsd-ports-gnome-3313f96c964f3b94b275ff22a0f8c04865a4e66a.tar.gz
freebsd-ports-gnome-3313f96c964f3b94b275ff22a0f8c04865a4e66a.tar.zst
freebsd-ports-gnome-3313f96c964f3b94b275ff22a0f8c04865a4e66a.zip
. Fix the PDF terminal.
PR: 104431 Submitted by: Roland Smith <rsmith@xs4all.nl>
Diffstat (limited to 'math')
-rw-r--r--math/gnuplot/Makefile2
-rw-r--r--math/gnuplot/files/patch-term-pdf.trm24
2 files changed, 20 insertions, 6 deletions
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index 40675b51ec5d..f4eed2f15505 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnuplot
PORTVERSION= 4.0.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= math graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/math/gnuplot/files/patch-term-pdf.trm b/math/gnuplot/files/patch-term-pdf.trm
index fe2bd870c475..1c18ff49f36f 100644
--- a/math/gnuplot/files/patch-term-pdf.trm
+++ b/math/gnuplot/files/patch-term-pdf.trm
@@ -1,13 +1,27 @@
$FreeBSD$
---- term/pdf.trm.orig Fri Jun 25 10:15:46 2004
-+++ term/pdf.trm Fri Jun 25 10:16:01 2004
-@@ -343,7 +343,7 @@
+--- term/pdf.trm.orig Sun Oct 15 11:10:22 2006
++++ term/pdf.trm Sun Oct 15 11:10:50 2006
+@@ -332,18 +332,13 @@
+ TERM_PUBLIC void
+ PDF_init ()
+ {
+- static TBOOLEAN PDFlib_booted = FALSE;
+-
+- if (!PDFlib_booted) {
+- PDF_boot();
+- PDFlib_booted = TRUE;
+- }
+-
++ extern char *outstr;
+ if (!myPDF)
myPDF = PDF_new();
- /*open new PDF file */
+- /*open new PDF file */
- if (PDF_open_fp(myPDF, gpoutfile) == -1)
-+ if (PDF_open_file(myPDF, gpoutfile) == -1)
++ /*open new PDF file */
++ fclose(gpoutfile);
++ if (PDF_begin_document(myPDF, outstr, 0, NULL) == -1)
int_error(NO_CARET, "Error:cannot open PDF file .\n");
#ifdef PDF_DONT_COMPRESS