aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2013-06-13 20:22:48 +0800
committerbsam <bsam@FreeBSD.org>2013-06-13 20:22:48 +0800
commit4a8920e711387a6341ac59dbd4a79d5905f90684 (patch)
treead65ab15e011b8a5f3038dd9a98ae333d6726329 /math
parentdac312bcc83f8d58f490e434ae51eb99af803fed (diff)
downloadfreebsd-ports-gnome-4a8920e711387a6341ac59dbd4a79d5905f90684.tar.gz
freebsd-ports-gnome-4a8920e711387a6341ac59dbd4a79d5905f90684.tar.zst
freebsd-ports-gnome-4a8920e711387a6341ac59dbd4a79d5905f90684.zip
. fix build with clang (CFLAGS+=-Wno-return-type);
. trim Makefile headers.
Diffstat (limited to 'math')
-rw-r--r--math/physcalc/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/math/physcalc/Makefile b/math/physcalc/Makefile
index 946e6c0c02c6..5d2fb87b614d 100644
--- a/math/physcalc/Makefile
+++ b/math/physcalc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: physcalc
-# Date created: Sun 27 Aug 2000
-# Whom: Will Andrews <andrews@technologist.com>
-#
+# Created by: Will Andrews <andrews@technologist.com>
# $FreeBSD$
-#
PORTNAME= physcalc
PORTVERSION= 2.4
@@ -24,6 +20,7 @@ USE_ZIP= yes
DEFS= -DSHAREDIR="\"${PREFIX}/share/physcalc/\""
SRCS= physconv.c physmain.c physmlib.c physnode.c physoper.c \
physsolv.c
+CFLAGS+= -Wno-return-type
pre-build:
${REINPLACE_CMD} -e "s@void main@int main@g" ${WRKSRC}/physmain.c