aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorljo <ljo@FreeBSD.org>1994-10-31 22:10:50 +0800
committerljo <ljo@FreeBSD.org>1994-10-31 22:10:50 +0800
commit5c9a9b6470ac74a7cf8a12529b78cd4c24eb1772 (patch)
tree269eb9d3604f8b2ec5d83a208f2865db8354ada4 /math
parent1c16da9c4741cc48a4f2354afab317e1a73dcc91 (diff)
downloadfreebsd-ports-gnome-5c9a9b6470ac74a7cf8a12529b78cd4c24eb1772.tar.gz
freebsd-ports-gnome-5c9a9b6470ac74a7cf8a12529b78cd4c24eb1772.tar.zst
freebsd-ports-gnome-5c9a9b6470ac74a7cf8a12529b78cd4c24eb1772.zip
Import of linpack library (Linear Algebra Package). This is the library
used in the linpack benchmark. However the purpose of this library is to be used in numerical methods applications.
Diffstat (limited to 'math')
-rw-r--r--math/linpack/Makefile42
-rw-r--r--math/linpack/files/Makefile.lib39
-rw-r--r--math/linpack/pkg-comment1
-rw-r--r--math/linpack/pkg-descr4
-rw-r--r--math/linpack/pkg-plist3
5 files changed, 89 insertions, 0 deletions
diff --git a/math/linpack/Makefile b/math/linpack/Makefile
new file mode 100644
index 000000000000..05dddf33ed94
--- /dev/null
+++ b/math/linpack/Makefile
@@ -0,0 +1,42 @@
+DISTNAME= linpack
+DISTDIR=${PORTSDIR}/distfiles/${DISTNAME}
+MASTER_SITES= ftp://netlib.att.com/netlib/linpack/
+EXTRACT_CMD=scripts/uncomp
+EXTRACT_SUFX=.Z
+EXTRACT_ARGS= ${WRKDIR}
+WRKSRC=${WRKDIR}
+
+SRCS = cchdc.f cchdd.f cchex.f cchud.f cgbco.f cgbdi.f cgbfa.f cgbsl.f \
+ cgeco.f cgedi.f cgefa.f cgesl.f cgtsl.f chico.f chidi.f chifa.f \
+ chisl.f chpco.f chpdi.f chpfa.f chpsl.f cmach.f cpbco.f cpbdi.f \
+ cpbfa.f cpbsl.f cpoco.f cpodi.f cpofa.f cposl.f cppco.f cppdi.f \
+ cppfa.f cppsl.f cptsl.f cqrdc.f cqrsl.f csico.f csidi.f csifa.f \
+ csisl.f cspco.f cspdi.f cspfa.f cspsl.f csvdc.f ctrco.f ctrdi.f \
+ ctrsl.f dchdc.f dchdd.f dchex.f dchud.f dgbco.f dgbdi.f dgbfa.f \
+ dgbsl.f dgeco.f dgedi.f dgefa.f dgesl.f dgtsl.f dmach.f dpbco.f \
+ dpbdi.f dpbfa.f dpbsl.f dpoco.f dpodi.f dpofa.f dposl.f dppco.f \
+ dppdi.f dppfa.f dppsl.f dptsl.f dqrdc.f dqrsl.f dsico.f dsidi.f \
+ dsifa.f dsisl.f dspco.f dspdi.f dspfa.f dspsl.f dsvdc.f dtrco.f \
+ dtrdi.f dtrsl.f schdc.f schdd.f schex.f schud.f sgbco.f sgbdi.f \
+ sgbfa.f sgbsl.f sgeco.f sgedi.f sgefa.f sgesl.f sgtsl.f smach.f \
+ spbco.f spbdi.f spbfa.f spbsl.f spoco.f spodi.f spofa.f sposl.f \
+ sppco.f sppdi.f sppfa.f sppsl.f sptsl.f sqrdc.f sqrsl.f ssico.f \
+ ssidi.f ssifa.f ssisl.f sspco.f sspdi.f sspfa.f sspsl.f ssvdc.f \
+ strco.f strdi.f strsl.f zchdc.f zchdd.f zchex.f zchud.f zgbco.f \
+ zgbdi.f zgbfa.f zgbsl.f zgeco.f zgedi.f zgefa.f zgesl.f zgtsl.f \
+ zhico.f zhidi.f zhifa.f zhisl.f zhpco.f zhpdi.f zhpfa.f zhpsl.f \
+ zmach.f zpbco.f zpbdi.f zpbfa.f zpbsl.f zpoco.f zpodi.f zpofa.f \
+ zposl.f zppco.f zppdi.f zppfa.f zppsl.f zptsl.f zqrdc.f zqrsl.f \
+ zsico.f zsidi.f zsifa.f zsisl.f zspco.f zspdi.f zspfa.f zspsl.f \
+ zsvdc.f ztrco.f ztrdi.f ztrsl.f
+
+DISTFILES= ${SRCS:.f=.f.Z}
+
+pre-build:
+ cp Makefile.lib ${WRKDIR}/Makefile
+
+pre-extract:
+ chmod +x scripts/uncomp
+
+.include <bsd.port.mk>
+
diff --git a/math/linpack/files/Makefile.lib b/math/linpack/files/Makefile.lib
new file mode 100644
index 000000000000..bed0736f916d
--- /dev/null
+++ b/math/linpack/files/Makefile.lib
@@ -0,0 +1,39 @@
+# @(#)Makefile 5.7 (Berkeley) 6/27/91
+
+# LINPACK sources
+LIBDIR= /usr/local/lib
+NOPROFILE= no
+
+SHLIB_MAJOR= 1
+SHLIB_MINOR= 0
+LIB=linpack
+SRCS = cchdc.f cchdd.f cchex.f cchud.f cgbco.f cgbdi.f cgbfa.f cgbsl.f \
+ cgeco.f cgedi.f cgefa.f cgesl.f cgtsl.f chico.f chidi.f chifa.f \
+ chisl.f chpco.f chpdi.f chpfa.f chpsl.f cmach.f cpbco.f cpbdi.f \
+ cpbfa.f cpbsl.f cpoco.f cpodi.f cpofa.f cposl.f cppco.f cppdi.f \
+ cppfa.f cppsl.f cptsl.f cqrdc.f cqrsl.f csico.f csidi.f csifa.f \
+ csisl.f cspco.f cspdi.f cspfa.f cspsl.f csvdc.f ctrco.f ctrdi.f \
+ ctrsl.f dchdc.f dchdd.f dchex.f dchud.f dgbco.f dgbdi.f dgbfa.f \
+ dgbsl.f dgeco.f dgedi.f dgefa.f dgesl.f dgtsl.f dmach.f dpbco.f \
+ dpbdi.f dpbfa.f dpbsl.f dpoco.f dpodi.f dpofa.f dposl.f dppco.f \
+ dppdi.f dppfa.f dppsl.f dptsl.f dqrdc.f dqrsl.f dsico.f dsidi.f \
+ dsifa.f dsisl.f dspco.f dspdi.f dspfa.f dspsl.f dsvdc.f dtrco.f \
+ dtrdi.f dtrsl.f schdc.f schdd.f schex.f schud.f sgbco.f sgbdi.f \
+ sgbfa.f sgbsl.f sgeco.f sgedi.f sgefa.f sgesl.f sgtsl.f smach.f \
+ spbco.f spbdi.f spbfa.f spbsl.f spoco.f spodi.f spofa.f sposl.f \
+ sppco.f sppdi.f sppfa.f sppsl.f sptsl.f sqrdc.f sqrsl.f ssico.f \
+ ssidi.f ssifa.f ssisl.f sspco.f sspdi.f sspfa.f sspsl.f ssvdc.f \
+ strco.f strdi.f strsl.f zchdc.f zchdd.f zchex.f zchud.f zgbco.f \
+ zgbdi.f zgbfa.f zgbsl.f zgeco.f zgedi.f zgefa.f zgesl.f zgtsl.f \
+ zhico.f zhidi.f zhifa.f zhisl.f zhpco.f zhpdi.f zhpfa.f zhpsl.f \
+ zmach.f zpbco.f zpbdi.f zpbfa.f zpbsl.f zpoco.f zpodi.f zpofa.f \
+ zposl.f zppco.f zppdi.f zppfa.f zppsl.f zptsl.f zqrdc.f zqrsl.f \
+ zsico.f zsidi.f zsifa.f zsisl.f zspco.f zspdi.f zspfa.f zspsl.f \
+ zsvdc.f ztrco.f ztrdi.f ztrsl.f
+CLEANFILES+= *.c
+
+package: install pkg/+DESC pkg/+ONELINE pkg/+PLIST
+ pkg_create -c pkg/+ONELINE -d pkg/+DESC -f pkg/+PLIST linpack_bin
+
+.include <bsd.lib.mk>
+
diff --git a/math/linpack/pkg-comment b/math/linpack/pkg-comment
new file mode 100644
index 000000000000..a5bdfff5cd4e
--- /dev/null
+++ b/math/linpack/pkg-comment
@@ -0,0 +1 @@
+Linpack, Linear Algebra package. \ No newline at end of file
diff --git a/math/linpack/pkg-descr b/math/linpack/pkg-descr
new file mode 100644
index 000000000000..29253078121f
--- /dev/null
+++ b/math/linpack/pkg-descr
@@ -0,0 +1,4 @@
+Developed by Jack Dongarra, Jim Bunch, Cleve Moler and Pete Stewart.
+ 1 Feb 84
+Used as part of Matlab, and often used to benchmark machines.
+Otherwise it is a very good linear algebra package.
diff --git a/math/linpack/pkg-plist b/math/linpack/pkg-plist
new file mode 100644
index 000000000000..946727aeaabd
--- /dev/null
+++ b/math/linpack/pkg-plist
@@ -0,0 +1,3 @@
+@cwd /usr/local
+lib/liblinpack.a
+lib/liblinpack.so.1.0