aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormatthew <matthew@FreeBSD.org>2016-05-22 18:52:44 +0800
committermatthew <matthew@FreeBSD.org>2016-05-22 18:52:44 +0800
commit5cdd27d7fb9e44673f9bb26594e8f14095624d86 (patch)
tree11614345c7dfeab8d4ba1cd03e07f16921dbc832 /math
parentae608736bd02e8d8d75614fe9b85e32072a72fda (diff)
downloadfreebsd-ports-gnome-5cdd27d7fb9e44673f9bb26594e8f14095624d86.tar.gz
freebsd-ports-gnome-5cdd27d7fb9e44673f9bb26594e8f14095624d86.tar.zst
freebsd-ports-gnome-5cdd27d7fb9e44673f9bb26594e8f14095624d86.zip
Reorganise and modernise the py-sqlalchemy ports.
- Introduce new ports for the sqlalchemy 0.9 and 1.0 release branches. - Deprecate the ports for the 0.6 and 0.7 release branches, as these have been declared EoL and are no longer supported by upstream. - Update to the latest available version in each branch. In detail: Port Version Maintainer ---------------------------------------------- py-sqlalchemy06 0.6.9 nivit@FreeBSD.org (Deprecate 2016-08-20) [1] py-sqlalchemy07 0.7.10 nivit@FreeBSD.org (renamed py-sqlalchemy, Deprecate 2016-08-20) [1] py-sqlalchemy08 0.8.7 nivit@FreeBSD.org (renamed py-sqlalchemy-devel) [1] py-sqlalchemy09 0.9.10 m.tsatsenko@gmail.com (new, repocopy from py-sqlalchemy-devel) [2] py-sqlalchemy10 1.0.13 m.tsatsenko@gmail.com (new, repocopy from py-sqlalchemy-devel) [2] - Use options-helpers and option dependent make targets. - Use autoplist for documents as well as python code - Add all the docments to the packages: previously an arbitrary subset was added in a way that excluded CSS, images and other HTML assets. - Use TEST_DEPENDS and add a TEST_TARGET instead of having a 'TEST' option. - Use py-pytest for 0.9.x and later, rather than py-nose. - Add CONFLICTS_INSTALL between all of the py-sqlalchemyXY ports. PR: 191442 Submitted by: robak Reviewed by: robak Reviewed by: pi Approved by: nivit (maintainer timeout, ~300days) [1] Approved by: m.tsatsenko@gmail.com (maintainer) [2] Sponsored by: https://reviews.freebsd.org/D908
Diffstat (limited to 'math')
-rw-r--r--math/py-pandas/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/math/py-pandas/Makefile b/math/py-pandas/Makefile
index b64ec8a7fc0d..64734467362e 100644
--- a/math/py-pandas/Makefile
+++ b/math/py-pandas/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS} \
TEST_DEPENDS:= ${RUN_DEPENDS} \
nosetests-${PYTHON_VER}:devel/py-nose \
cython:lang/cython \
- ${PYTHON_PKGNAMEPREFIX}sqlalchemy>0:databases/py-sqlalchemy \
+ ${PYTHON_PKGNAMEPREFIX}sqlalchemy08>0:databases/py-sqlalchemy08 \
${PYTHON_PKGNAMEPREFIX}boto>0:devel/py-boto \
${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml \
${PYTHON_PKGNAMEPREFIX}tables>=3.0.0:devel/py-tables \
@@ -51,7 +51,7 @@ BTLNCK_DESC= Accelerate certain NaN evals via math/py-bottleneck
NUMEXPR_DESC= Accelerate certain numerical ops via math/py-numexpr
BOTO_DESC= Support Amazon S3 storage via devel/py-boto
TABLES_DESC= Support HDF5-based storage via devel/py-tables
-SQL_DESC= Support SQL databases via databases/py-sqlalchemy
+SQL_DESC= Support SQL databases via databases/py-sqlalchemy08
LXML_DESC= Parse HTML with devel/py-lxml and www/py-beautifulsoup
JINJA2_DESC= Support conditional HTML formatting with devel/py-Jinja2
HTML5LIB_DESC= Parse HTML with www/py-html5lib and www/py-beautifulsoup
@@ -70,12 +70,7 @@ BTLNCK_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bottleneck>0:math/py-bottleneck
NUMEXPR_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numexpr>=2.1.0:math/py-numexpr
BOTO_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}boto>0:devel/py-boto
TABLES_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tables>=3.0.0:devel/py-tables
-# Note: upstream recommends SQLAlchemy 0.8.1 or higher, which is not
-# available in the ports tree as of this writing
-# See: https://reviews.freebsd.org/D908
-# See: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=191442
-# See: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=205852
-SQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy>0:databases/py-sqlalchemy
+SQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy08>0:databases/py-sqlalchemy08
LXML_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml
HTML5LIB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}html5lib>0:www/py-html5lib