aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-30 03:11:51 +0800
committeradamw <adamw@FreeBSD.org>2014-07-30 03:11:51 +0800
commit5d4f6dbf6920e86fef1c7e3a8e60608b5d4f4764 (patch)
tree97c04ac5ad39d0af4b856d37b17a5a074d6adbc6 /math
parent1797fa8d15fb48b349a9dcceef649bf7bbbc52c3 (diff)
downloadfreebsd-ports-gnome-5d4f6dbf6920e86fef1c7e3a8e60608b5d4f4764.tar.gz
freebsd-ports-gnome-5d4f6dbf6920e86fef1c7e3a8e60608b5d4f4764.tar.zst
freebsd-ports-gnome-5d4f6dbf6920e86fef1c7e3a8e60608b5d4f4764.zip
Convert a bunch of EXTRACT_SUFX=... into USES=tar:...
Approved by: portmgr (not really, but touches unstaged ports)
Diffstat (limited to 'math')
-rw-r--r--math/algotutor/Makefile3
-rw-r--r--math/asymptote/Makefile3
-rw-r--r--math/bargraph/Makefile3
-rw-r--r--math/blocksolve95/Makefile3
-rw-r--r--math/carve/Makefile3
-rw-r--r--math/clp/Makefile3
-rw-r--r--math/dieharder/Makefile3
-rw-r--r--math/fxt/Makefile3
-rw-r--r--math/goblin/Makefile3
-rw-r--r--math/lapack95/Makefile3
-rw-r--r--math/lapacke/Makefile3
-rw-r--r--math/levmar/Makefile3
-rw-r--r--math/p5-Math-BaseCnv/Makefile3
-rw-r--r--math/p5-Math-Gradient/Makefile3
-rw-r--r--math/proofgeneral/Makefile3
-rw-r--r--math/qhull/Makefile3
-rw-r--r--math/qwtplot3d-qt4/Makefile3
-rw-r--r--math/spooles/Makefile3
-rw-r--r--math/taucs/Makefile3
19 files changed, 19 insertions, 38 deletions
diff --git a/math/algotutor/Makefile b/math/algotutor/Makefile
index 73c19b1a8b5e..b09ecc8730a9 100644
--- a/math/algotutor/Makefile
+++ b/math/algotutor/Makefile
@@ -5,7 +5,6 @@ PORTVERSION= 0.8.6
PORTREVISION= 4
CATEGORIES= math
MASTER_SITES= http://www.cyut.edu.tw/~ckhung/dl/
-EXTRACT_SUFX= .tgz
MAINTAINER= kevlo@FreeBSD.org
COMMENT= Interactive tutorial for algorithms and data structures
@@ -23,7 +22,7 @@ LIBFILES= BST.pm Board.pm Collection.pm Configurable.pm DCEdge.pm \
RecCanvas.pm RecDialog.pm TreeNode.pm Vector.pm Vector2.pm \
Vector3.pm Vertex.pm basic.pl utilalgo
-USES= shebangfix perl5
+USES= shebangfix perl5 tar:tgz
SHEBANG_FILES= algotutor
post-patch:
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index 71ba6cb9aa4a..7e4af8a6b71b 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -8,7 +8,6 @@ CATEGORIES= math
MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
-EXTRACT_SUFX= .tgz
MAINTAINER= nivit@FreeBSD.org
COMMENT= Powerful script-based vector graphics language
@@ -36,7 +35,7 @@ MAKE_JOBS_UNSAFE= yes
ONLY_FOR_ARCHS= i386 amd64
-USES= gmake perl5
+USES= gmake perl5 tar:tgz
USE_AUTOTOOLS= autoconf aclocal
USE_GHOSTSCRIPT=yes
USE_GL= glut
diff --git a/math/bargraph/Makefile b/math/bargraph/Makefile
index 54c94b29205d..bcb5cd085aed 100644
--- a/math/bargraph/Makefile
+++ b/math/bargraph/Makefile
@@ -7,7 +7,6 @@ PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= http://bargraphgen.googlecode.com/files/
DISTNAME= bargraphgen-${PORTVERSION}
-EXTRACT_SUFX= .tgz
MAINTAINER= dereckson@gmail.com
COMMENT= Scriptable bar graph generator
@@ -17,7 +16,7 @@ LICENSE= GPLv2
RUN_DEPENDS= ${LOCALBASE}/bin/fig2dev:${PORTSDIR}/print/transfig \
${LOCALBASE}/bin/gnuplot:${PORTSDIR}/math/gnuplot
-USES= perl5 shebangfix
+USES= perl5 shebangfix tar:tgz
NO_WRKSUBDIR= yes
NO_BUILD= yes
SHEBANG_FILES= bargraph.pl
diff --git a/math/blocksolve95/Makefile b/math/blocksolve95/Makefile
index a518c060d8bc..c2f33c2e7462 100644
--- a/math/blocksolve95/Makefile
+++ b/math/blocksolve95/Makefile
@@ -8,7 +8,6 @@ CATEGORIES= math parallel
MASTER_SITES= ftp://ftp.mcs.anl.gov/pub/BlockSolve95/ \
http://ftp.mcs.anl.gov/pub/BlockSolve95/
DISTNAME= BlockSolve95
-EXTRACT_SUFX= .tar.Z
DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
@@ -18,7 +17,7 @@ BUILD_DEPENDS= ${MPIDIR}/lib/libmpich.a:${PORTSDIR}/net/mpich2
LIB_DEPENDS= libf2c.so:${PORTSDIR}/lang/f2c
RUN_DEPENDS= ${MPIDIR}/bin/mpirun:${PORTSDIR}/net/mpich2
-USES= fortran gmake
+USES= fortran gmake tar:Z
MAKEFILE= makefile
MAKE_ARGS= GMAKE=${MAKE_CMD} PETSC_ARCH=${PETSC_ARCH} BOPT=${BOPT} \
BLAS_LIB="${BLAS_LIB}" LAPACK_LIB="${LAPACK_LIB}"
diff --git a/math/carve/Makefile b/math/carve/Makefile
index e605f656cd37..1905a89c169b 100644
--- a/math/carve/Makefile
+++ b/math/carve/Makefile
@@ -6,7 +6,6 @@ PORTVERSION= 1.4.0
PORTREVISION= 4
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
-EXTRACT_SUFX= .tgz
MAINTAINER= gahr@FreeBSD.org
COMMENT= Fast, robust constructive solid geometry library
@@ -17,7 +16,7 @@ LIB_DEPENDS= libboost_filesystem.so:${PORTSDIR}/devel/boost-libs
OPTIONS_DEFINE= DOCS GUI
-USES= cmake:outsource compiler:c++11-lib
+USES= cmake:outsource compiler:c++11-lib tar:tgz
USE_GL= glut
USE_LDCONFIG= yes
diff --git a/math/clp/Makefile b/math/clp/Makefile
index 75f92bf14d7d..685d4426c678 100644
--- a/math/clp/Makefile
+++ b/math/clp/Makefile
@@ -7,14 +7,13 @@ PORTREVISION= 3
CATEGORIES= math
MASTER_SITES= http://www.coin-or.org/download/source/Clp/ \
http://www.mavetju.org/download/adopted/
-EXTRACT_SUFX= .tgz
MAINTAINER= co9co9@gmail.com
COMMENT= Linear Programming Solver
LIB_DEPENDS= liblapack.so:${PORTSDIR}/math/lapack
-USES= fortran libtool
+USES= fortran libtool tar:tgz
CXXFLAGS+= -ffast-math -fomit-frame-pointer
GNU_CONFIGURE= yes
diff --git a/math/dieharder/Makefile b/math/dieharder/Makefile
index c7974d04eed6..bf32f88181dd 100644
--- a/math/dieharder/Makefile
+++ b/math/dieharder/Makefile
@@ -6,7 +6,6 @@ PORTVERSION= 3.31.1
PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= http://www.phy.duke.edu/~rgb/General/dieharder/ LOCAL/bf
-EXTRACT_SUFX= .tgz
MAINTAINER= bf@FreeBSD.org
COMMENT= Random number generator testsuite
@@ -17,7 +16,7 @@ LIB_DEPENDS= libgsl.so:${PORTSDIR}/math/gsl
MAKE_JOBS_UNSAFE= yes
-USES= dos2unix libtool
+USES= dos2unix libtool tar:tgz
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/math/fxt/Makefile b/math/fxt/Makefile
index a65a21b141cc..41868c20b519 100644
--- a/math/fxt/Makefile
+++ b/math/fxt/Makefile
@@ -5,14 +5,13 @@ PORTNAME= fxt
PORTVERSION= 2012.06.18
CATEGORIES= math
MASTER_SITES= http://www.jjj.de/fxt/
-EXTRACT_SUFX= .tgz
MAINTAINER= dhn@FreeBSD.org
COMMENT= FFT code and related stuff
WRKSRC= ${WRKDIR}/${PORTNAME}
-USES= gmake
+USES= gmake tar:tgz
MAKEFILE= makefile
OPTIONS_DEFINE= DOCS EXAMPLES
diff --git a/math/goblin/Makefile b/math/goblin/Makefile
index 10e329a47846..3c7d7bdcc358 100644
--- a/math/goblin/Makefile
+++ b/math/goblin/Makefile
@@ -6,7 +6,6 @@ DISTVERSION= 2.8b30
CATEGORIES= math
MASTER_SITES= SF/${PORTNAME}2/${PORTNAME}2/${PORTNAME}.${DISTVERSION}
DISTNAME= ${PORTNAME}.${DISTVERSION}
-EXTRACT_SUFX= .tgz
MAINTAINER= gahr@FreeBSD.org
COMMENT= Graph Object Library for Network Programming Problems
@@ -15,7 +14,7 @@ CONFLICTS= glpk-*
OPTIONS_DEFINE= DOCS EXAMPLES
-USES= gmake tk
+USES= gmake tk tar:tgz
USE_LDCONFIG= yes
MAKE_ARGS= CC="${CC}" CCFLAGS="${CFLAGS}" \
CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
diff --git a/math/lapack95/Makefile b/math/lapack95/Makefile
index 247170b47019..9790332a2b3f 100644
--- a/math/lapack95/Makefile
+++ b/math/lapack95/Makefile
@@ -7,13 +7,12 @@ PORTREVISION= 8
CATEGORIES= math
MASTER_SITES= NL
DISTNAME= ${PORTNAME}
-EXTRACT_SUFX= .tgz
DIST_SUBDIR= lapack95
MAINTAINER= ports@FreeBSD.org
COMMENT= LAPACK95, Fortran90/95 wrapper for LAPACK
-USES= fortran
+USES= fortran tar:tgz
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/LAPACK95
diff --git a/math/lapacke/Makefile b/math/lapacke/Makefile
index c7dfe274c4a4..1f62c9693527 100644
--- a/math/lapacke/Makefile
+++ b/math/lapacke/Makefile
@@ -7,7 +7,6 @@ CATEGORIES= math
MASTER_SITES= NL
MASTER_SITE_SUBDIR= lapack
DISTNAME= lapack-${PORTVERSION}
-EXTRACT_SUFX= .tgz
DIST_SUBDIR= lapack
MAINTAINER= phd_kimberlite@yahoo.co.jp
@@ -17,7 +16,7 @@ LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/LICENSE
USE_LDCONFIG= yes
-USES= fortran
+USES= fortran tar:tgz
OPTIONS_DEFINE= PROFILE XLAPACKE DOCS
PROFILE_DESC= Build a profiling library
diff --git a/math/levmar/Makefile b/math/levmar/Makefile
index d1b6b450da42..281d0384c55e 100644
--- a/math/levmar/Makefile
+++ b/math/levmar/Makefile
@@ -6,7 +6,6 @@ PORTVERSION= 2.6
PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= http://users.ics.forth.gr/~lourakis/levmar/
-EXTRACT_SUFX= .tgz
MAINTAINER= phd_kimberlite@yahoo.co.jp
COMMENT= GPL-licensed library implementing the Levenberg-Marquardt algorithm
@@ -15,7 +14,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
USE_LDCONFIG= yes
-USES= fortran
+USES= fortran tar:tgz
OPTIONS_DEFINE= DOCS EXAMPLES PROFILE
PROFILE_DESC= Build a profiling library
diff --git a/math/p5-Math-BaseCnv/Makefile b/math/p5-Math-BaseCnv/Makefile
index 6b23d2584d90..29d802068491 100644
--- a/math/p5-Math-BaseCnv/Makefile
+++ b/math/p5-Math-BaseCnv/Makefile
@@ -7,7 +7,6 @@ CATEGORIES= math perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
DISTNAME= ${PORTNAME}-${PORTVERSION}O6Pbr
-EXTRACT_SUFX= .tgz
MAINTAINER= perl@FreeBSD.org
COMMENT= Fast functions to convert between number Bases
@@ -16,7 +15,7 @@ BUILD_DEPENDS= p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod \
p5-Test-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Test-Pod-Coverage
RUN_DEPENDS= p5-Memoize>=0:${PORTSDIR}/devel/p5-Memoize
-USES= perl5
+USES= perl5 tar:tgz
USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/math/p5-Math-Gradient/Makefile b/math/p5-Math-Gradient/Makefile
index c6fbd9e1c05c..6de85da21e0b 100644
--- a/math/p5-Math-Gradient/Makefile
+++ b/math/p5-Math-Gradient/Makefile
@@ -6,12 +6,11 @@ PORTVERSION= 0.04
CATEGORIES= math perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-EXTRACT_SUFX= .tgz
MAINTAINER= perl@FreeBSD.org
COMMENT= Calculating gradients for color transitions and the like
-USES= perl5
+USES= perl5 tar:tgz
USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/math/proofgeneral/Makefile b/math/proofgeneral/Makefile
index 9ac56b16f2c8..618f354206e6 100644
--- a/math/proofgeneral/Makefile
+++ b/math/proofgeneral/Makefile
@@ -8,7 +8,6 @@ CATEGORIES= math elisp
MASTER_SITES= http://proofgeneral.inf.ed.ac.uk/releases/
PKGNAMESUFFIX= -${EMACS_NAME}
DISTNAME= ProofGeneral-${PORTVERSION}
-EXTRACT_SUFX= .tgz
MAINTAINER= beyert@cs.ucr.edu
COMMENT= Generic interface for proof assistants
@@ -21,7 +20,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicol
USE_EMACS= yes
INSTALLS_ICONS= yes
-USES= gmake perl5 shebangfix
+USES= gmake perl5 shebangfix tar:tgz
SHEBANG_FILES= lego/legotags coq/coqtags isar/isartags
.include <bsd.port.pre.mk>
diff --git a/math/qhull/Makefile b/math/qhull/Makefile
index 207e7350cecb..d48e8f1f0500 100644
--- a/math/qhull/Makefile
+++ b/math/qhull/Makefile
@@ -6,12 +6,11 @@ PORTVERSION= 2012.1
CATEGORIES= math
MASTER_SITES= http://www.qhull.org/download/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
-EXTRACT_SUFX= .tgz
MAINTAINER= stephen@FreeBSD.org
COMMENT= Qhull computes convex hulls, Delaunay triangulations, and halfspaces
-USES= cmake
+USES= cmake tar:tgz
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/math/qwtplot3d-qt4/Makefile b/math/qwtplot3d-qt4/Makefile
index a26df193176d..0f0668cef00b 100644
--- a/math/qwtplot3d-qt4/Makefile
+++ b/math/qwtplot3d-qt4/Makefile
@@ -6,12 +6,11 @@ PORTREVISION= 4
CATEGORIES= math
MASTER_SITES= SF
PKGNAMESUFFIX= -qt4
-EXTRACT_SUFX= .tgz
MAINTAINER= makc@FreeBSD.org
COMMENT= 3D plotting widgets for scientific data and math expressions
-USES= dos2unix qmake
+USES= dos2unix qmake tar:tgz
USE_QT4= gui moc_build opengl
USE_GL= glu
USE_LDCONFIG= yes
diff --git a/math/spooles/Makefile b/math/spooles/Makefile
index da293a7eebe1..45c694e9e05a 100644
--- a/math/spooles/Makefile
+++ b/math/spooles/Makefile
@@ -10,7 +10,6 @@ MASTER_SITES= http://www.netlib.org/linalg/spooles/
PKGNAMESUFFIX= -mpich
.endif
DISTNAME= ${PORTNAME}.${PORTVERSION}
-EXTRACT_SUFX= .tgz
DIST_SUBDIR= spooles
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
@@ -21,7 +20,7 @@ COMMENT= SParse Object Oriented Linear Equations Solver
BUILD_DEPENDS= ${LOCALBASE}/lib/libmpich.a:${PORTSDIR}/net/mpich2
.endif
-USES= gmake
+USES= gmake tar:tgz
.if defined(WITH_MPI)
PLIST_SUB+= MPI=""
diff --git a/math/taucs/Makefile b/math/taucs/Makefile
index e09037dbebcb..bd565bdc8c62 100644
--- a/math/taucs/Makefile
+++ b/math/taucs/Makefile
@@ -8,7 +8,6 @@ CATEGORIES= math
MASTER_SITES= http://www.tau.ac.il/~stoledo/taucs/${PORTVERSION}/ \
LOCAL/bf
DISTNAME= ${PORTNAME}
-EXTRACT_SUFX= .tgz
MAINTAINER= bf@FreeBSD.org
COMMENT= C library of sparse linear solvers
@@ -16,7 +15,7 @@ COMMENT= C library of sparse linear solvers
LIB_DEPENDS= libmetis.so:${PORTSDIR}/math/metis4
HAS_CONFIGURE= yes
-USES= fortran
+USES= fortran tar:tgz
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}