aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2014-09-05 02:21:20 +0800
committermakc <makc@FreeBSD.org>2014-09-05 02:21:20 +0800
commit61483f793721b2c4a6eb43a217d8e4666093ee75 (patch)
tree6cf5bd8e7cb9a53d66ab9414ed02cf775b5da328 /math
parente7aa828d61d9e9590d41a05ce6eb07ca4ca575ca (diff)
downloadfreebsd-ports-gnome-61483f793721b2c4a6eb43a217d8e4666093ee75.tar.gz
freebsd-ports-gnome-61483f793721b2c4a6eb43a217d8e4666093ee75.tar.zst
freebsd-ports-gnome-61483f793721b2c4a6eb43a217d8e4666093ee75.zip
math/scilab-toolbox-swt:
- Update to 0.1.20 - Don't require X for documentation building - USE_GCC=any - Convert to options helpers
Diffstat (limited to 'math')
-rw-r--r--math/scilab-toolbox-swt/Makefile30
-rw-r--r--math/scilab-toolbox-swt/distinfo4
-rw-r--r--math/scilab-toolbox-swt/files/extrapatch-etc__swt.start13
-rw-r--r--math/scilab-toolbox-swt/pkg-descr3
-rw-r--r--math/scilab-toolbox-swt/pkg-plist115
5 files changed, 125 insertions, 40 deletions
diff --git a/math/scilab-toolbox-swt/Makefile b/math/scilab-toolbox-swt/Makefile
index 264a4cd9e557..75c8ac6e1df4 100644
--- a/math/scilab-toolbox-swt/Makefile
+++ b/math/scilab-toolbox-swt/Makefile
@@ -1,12 +1,11 @@
# $FreeBSD$
PORTNAME= swt
-PORTVERSION= 0.1.11
-PORTREVISION= 3
+PORTVERSION= 0.1.20
CATEGORIES= math
MASTER_SITES= http://atoms.scilab.org/toolboxes/swt/${PORTVERSION}/files/
PKGNAMEPREFIX= scilab-toolbox-
-DISTFILES= ${DISTNAME}-1-src${EXTRACT_SUFX}
+DISTFILES= ${DISTNAME}-3-src${EXTRACT_SUFX}
MAINTAINER= makc@FreeBSD.org
COMMENT= Scilab 1-D and 2-D Wavelet Toolbox
@@ -14,7 +13,12 @@ COMMENT= Scilab 1-D and 2-D Wavelet Toolbox
BUILD_DEPENDS= ${SCILAB_CMD}:${PORTSDIR}/math/scilab
RUN_DEPENDS:= ${BUILD_DEPENDS}
-SCILAB_CMD= ${LOCALBASE}/bin/scilab
+USE_GCC= any
+
+SCILAB_CMD= ${LOCALBASE}/bin/scilab-adv-cli
+SCILAB_ARGS= -noatomsautoload -nb -nouserstartup
+MAKE_ENV= LC_ALL="C" SCI_JAVA_ENABLE_HEADLESS=1 SCI_DISABLE_TK=1
+
CONTRIBDIR?= share/scilab/contrib
TOOLBOXDIR_REL?= ${CONTRIBDIR}/${PORTNAME}
TOOLBOXDIR= ${PREFIX}/${TOOLBOXDIR_REL}
@@ -23,24 +27,20 @@ TOOLBOX_SUBDIRS= demos etc macros
OPTIONS_DEFINE= HELP SIVP
OPTIONS_DEFAULT= HELP
+OPTIONS_SUB= yes
HELP_DESC= Build help files (requires scilab with gui support)
SIVP_DESC= Enable Image and Video support
+SIVP_RUN_DEPENDS= ${LOCALBASE}/${CONTRIBDIR}/sivp/loader.sce:${PORTSDIR}/math/scilab-toolbox-sivp
-.include <bsd.port.options.mk>
+WRKSRC= ${WRKDIR}/swt
-.if ${PORT_OPTIONS:MSIVP}
-RUN_DEPENDS+= ${LOCALBASE}/${CONTRIBDIR}/sivp/loader.sce:${PORTSDIR}/math/scilab-toolbox-sivp
-.endif
+.include <bsd.port.options.mk>
.if !${PORT_OPTIONS:MHELP}
-SCILAB_ARGS= -nogui
-PLIST_SUB+= HELP="@comment "
+SCILAB_ARGS+= -nwni
EXTRA_PATCHES+= ${FILESDIR}/extrapatch-etc__swt.start
.else
-USES+= display:build
-MAKE_ENV= LC_ALL="C"
-PLIST_SUB+= HELP=""
TOOLBOX_SUBDIRS+= jar
.endif
@@ -48,8 +48,8 @@ post-patch:
.if !${PORT_OPTIONS:MHELP}
${REINPLACE_CMD} -e '/tbx_builder_help/d' ${WRKSRC}/builder.sce
.endif
- ${REINPLACE_CMD} -e "s,SWTDIR+','${TOOLBOXDIR}/demos," \
- ${WRKSRC}/demos/image.sce
+ ${REINPLACE_CMD} -e '/#include <malloc.h>/d' \
+ ${WRKSRC}/sci_gateway/c/kiss_fft.h
${ECHO_CMD} quit >> ${WRKSRC}/builder.sce
pre-build:
diff --git a/math/scilab-toolbox-swt/distinfo b/math/scilab-toolbox-swt/distinfo
index a9aed074af8a..b96daa6ffb03 100644
--- a/math/scilab-toolbox-swt/distinfo
+++ b/math/scilab-toolbox-swt/distinfo
@@ -1,2 +1,2 @@
-SHA256 (swt-0.1.11-1-src.tar.gz) = aef26dd3a2c45ba00605bf79ba4bd6e1809eee67ca48cee7573fc7c11d159efc
-SIZE (swt-0.1.11-1-src.tar.gz) = 677437
+SHA256 (swt-0.1.20-3-src.tar.gz) = a0edfd25c4a5831d2953c45fdb9289fbba006149a6581dad84a8803293aaffeb
+SIZE (swt-0.1.20-3-src.tar.gz) = 945095
diff --git a/math/scilab-toolbox-swt/files/extrapatch-etc__swt.start b/math/scilab-toolbox-swt/files/extrapatch-etc__swt.start
index 4b9e07f0262d..c57355b29832 100644
--- a/math/scilab-toolbox-swt/files/extrapatch-etc__swt.start
+++ b/math/scilab-toolbox-swt/files/extrapatch-etc__swt.start
@@ -1,6 +1,6 @@
---- ./etc/swt.start.orig 2010-08-30 12:52:10.000000000 +0400
-+++ ./etc/swt.start 2010-10-17 16:02:57.850107854 +0400
-@@ -34,15 +34,6 @@
+--- ./etc/swt.start.orig 2014-05-07 16:06:39.000000000 +0000
++++ ./etc/swt.start 2014-09-04 09:17:50.853642536 +0000
+@@ -33,13 +33,7 @@
// Load and add help chapter
// =============================================================================
@@ -9,10 +9,9 @@
- path_addchapter = pathconvert(root_tlbx+"/jar");
- if ( isdir(path_addchapter) <> [] ) then
- add_help_chapter("swt", path_addchapter, %F);
-- clear add_help_chapter;
- end
-- clear path_addchapter;
-end
++
-
- clear root_tlbx;
+ // Load demos
+ // =============================================================================
diff --git a/math/scilab-toolbox-swt/pkg-descr b/math/scilab-toolbox-swt/pkg-descr
index 0a345fa519b5..616168da25c0 100644
--- a/math/scilab-toolbox-swt/pkg-descr
+++ b/math/scilab-toolbox-swt/pkg-descr
@@ -14,5 +14,4 @@ Discrete Fast Wavelet Transform, daubechies wavelets
2-D single level image decomposition and reconstruction
2-D multi-level image decomposition and reconstruction.
-WWW: http://scwt.sourceforge.net
-WWW: http://atoms.scilab.org/toolboxes/swt
+WWW: http://atoms.scilab.org/toolboxes/swt
diff --git a/math/scilab-toolbox-swt/pkg-plist b/math/scilab-toolbox-swt/pkg-plist
index eabfaac790a6..e706c2bc41c5 100644
--- a/math/scilab-toolbox-swt/pkg-plist
+++ b/math/scilab-toolbox-swt/pkg-plist
@@ -1,51 +1,137 @@
%%TOOLBOXDIR%%/demos/cowt1d.sce
%%TOOLBOXDIR%%/demos/cowt2d.sce
%%TOOLBOXDIR%%/demos/cwt.sce
+%%TOOLBOXDIR%%/demos/cwt_chirp.sce
+%%TOOLBOXDIR%%/demos/diff_cwt.dem.sce
%%TOOLBOXDIR%%/demos/dwtmode.dem.sce
%%TOOLBOXDIR%%/demos/image.sce
%%TOOLBOXDIR%%/demos/image/woman.bmp
+%%TOOLBOXDIR%%/demos/image/woman.dat
%%TOOLBOXDIR%%/demos/rwt.sce
%%TOOLBOXDIR%%/demos/scale2freq.dem.sce
+%%TOOLBOXDIR%%/demos/smoothness_wav.dem.sce
%%TOOLBOXDIR%%/demos/swt.dem.gateway.sce
%%TOOLBOXDIR%%/demos/swt1d.sce
%%TOOLBOXDIR%%/demos/swt2d.sce
%%TOOLBOXDIR%%/demos/swt3d.sce
%%TOOLBOXDIR%%/demos/swtswt.sce
%%TOOLBOXDIR%%/demos/wavedec.dem.sce
+%%TOOLBOXDIR%%/demos/wavelet_fam.dem.sce
+%%TOOLBOXDIR%%/demos/wavelet_scale.dem.sce
%%TOOLBOXDIR%%/demos/wden.dem.sce
%%TOOLBOXDIR%%/etc/swt.quit
%%TOOLBOXDIR%%/etc/swt.start
%%HELP%%%%TOOLBOXDIR%%/jar/scilab_en_US_help.jar
%%TOOLBOXDIR%%/loader.sce
-%%TOOLBOXDIR%%/macros/ShapeAsRow.bin
-%%TOOLBOXDIR%%/macros/ShapeAsRow.sci
%%TOOLBOXDIR%%/macros/buildmacros.sce
%%TOOLBOXDIR%%/macros/centfrq.bin
%%TOOLBOXDIR%%/macros/centfrq.sci
-%%TOOLBOXDIR%%/macros/cwt_wavelab.bin
-%%TOOLBOXDIR%%/macros/cwt_wavelab.sci
+%%TOOLBOXDIR%%/macros/cleanmacros.sce
%%TOOLBOXDIR%%/macros/cwtplot.bin
%%TOOLBOXDIR%%/macros/cwtplot.sci
%%TOOLBOXDIR%%/macros/ddencmp.bin
%%TOOLBOXDIR%%/macros/ddencmp.sci
+%%TOOLBOXDIR%%/macros/dwtplot.bin
+%%TOOLBOXDIR%%/macros/dwtplot.sci
+%%TOOLBOXDIR%%/macros/get_swt_path.bin
+%%TOOLBOXDIR%%/macros/get_swt_path.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/DOGauss.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/FSfarras.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/appcoef.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/appcoef2.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/biorfilt.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/biorwavf.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/cauwavf.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/cgauwavf.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/cmorwavf.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/coifwavf.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/cplxdual2D.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/cwt.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/dbwavf.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/detcoef.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/detcoef2.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/dualfilt1.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/dualtree.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/dualtree2D.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/dwt.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/dwt2.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/dwt3.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/dwtmode.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/dyaddown.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/dyadup.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/fbspwavf.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/gauswavf.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/iconv.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/icplxdual2D.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/idualtree.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/idualtree2D.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/idwt.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/idwt2.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/idwt3.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/ind2rgb.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/iswt.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/iswt2.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/legdwavf.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/mexihat.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/morlet.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/orthfilt.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/poisson.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/qmf.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/rbiorwavf.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/shanwavf.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/sinus.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/swt.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/swt2.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/symwavf.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/upcoef.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/upcoef2.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/upwlev.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/upwlev2.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/wavedec.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/wavedec2.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/wavefun.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/wavefun2.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/waveletfamilies.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/waverec.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/waverec2.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/wcodemat.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/wenergy.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/wenergy2.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/wextend.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/wfilters.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/wkeep.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/wmaxlev.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/wnorm.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/wrcoef.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/wrcoef2.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/wrev.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/wrev2.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/wrev3.sci
+%%TOOLBOXDIR%%/macros/help_from_sci/wrot3.sci
+%%TOOLBOXDIR%%/macros/indwt.bin
+%%TOOLBOXDIR%%/macros/indwt.sci
+%%TOOLBOXDIR%%/macros/indwt2.bin
+%%TOOLBOXDIR%%/macros/indwt2.sci
%%TOOLBOXDIR%%/macros/lib
-%%TOOLBOXDIR%%/macros/lshift.bin
-%%TOOLBOXDIR%%/macros/lshift.sci
-%%TOOLBOXDIR%%/macros/mm_rwt.bin
-%%TOOLBOXDIR%%/macros/mm_rwt.sci
+%%TOOLBOXDIR%%/macros/meyer.bin
+%%TOOLBOXDIR%%/macros/meyer.sci
%%TOOLBOXDIR%%/macros/names
-%%TOOLBOXDIR%%/macros/rshift.bin
-%%TOOLBOXDIR%%/macros/rshift.sci
-%%TOOLBOXDIR%%/macros/rwt.bin
-%%TOOLBOXDIR%%/macros/rwt.sci
+%%TOOLBOXDIR%%/macros/ndwt.bin
+%%TOOLBOXDIR%%/macros/ndwt.sci
+%%TOOLBOXDIR%%/macros/ndwt2.bin
+%%TOOLBOXDIR%%/macros/ndwt2.sci
%%TOOLBOXDIR%%/macros/scal2frq.bin
%%TOOLBOXDIR%%/macros/scal2frq.sci
%%TOOLBOXDIR%%/macros/thselect.bin
%%TOOLBOXDIR%%/macros/thselect.sci
%%TOOLBOXDIR%%/macros/wavedecplot.bin
%%TOOLBOXDIR%%/macros/wavedecplot.sci
+%%TOOLBOXDIR%%/macros/wbmpen.bin
+%%TOOLBOXDIR%%/macros/wbmpen.sci
%%TOOLBOXDIR%%/macros/wden.bin
%%TOOLBOXDIR%%/macros/wden.sci
+%%TOOLBOXDIR%%/macros/wdencmp.bin
+%%TOOLBOXDIR%%/macros/wdencmp.sci
%%TOOLBOXDIR%%/macros/wentropy.bin
%%TOOLBOXDIR%%/macros/wentropy.sci
%%TOOLBOXDIR%%/macros/wnoise.bin
@@ -54,13 +140,14 @@
%%TOOLBOXDIR%%/macros/wnoisest.sci
%%TOOLBOXDIR%%/macros/wthresh.bin
%%TOOLBOXDIR%%/macros/wthresh.sci
-%%TOOLBOXDIR%%/macros/wtmm.bin
-%%TOOLBOXDIR%%/macros/wtmm.sci
+%%TOOLBOXDIR%%/macros/wthrmngr.bin
+%%TOOLBOXDIR%%/macros/wthrmngr.sci
%%TOOLBOXDIR%%/sci_gateway/c/libswt_c.so
%%TOOLBOXDIR%%/sci_gateway/c/loader.sce
%%TOOLBOXDIR%%/sci_gateway/loader_gateway.sce
@dirrm %%TOOLBOXDIR%%/sci_gateway/c
@dirrm %%TOOLBOXDIR%%/sci_gateway
+@dirrm %%TOOLBOXDIR%%/macros/help_from_sci
@dirrm %%TOOLBOXDIR%%/macros
%%HELP%%@dirrm %%TOOLBOXDIR%%/jar
@dirrm %%TOOLBOXDIR%%/etc