aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2013-08-18 00:27:24 +0800
committergerald <gerald@FreeBSD.org>2013-08-18 00:27:24 +0800
commit92621d361d009a9f1c5fbfe137cf9e878dbe34cf (patch)
treec1657d06d35b5f160b90b16620933ca757495766 /math
parent9e9651b8c9f8d3ec1375dfb2e0d48a491ad6c121 (diff)
downloadfreebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.tar.gz
freebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.tar.zst
freebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.zip
Replace USE_GCC=4.6+ and USE_GCC=4.4+ by USE_GCC=yes.
Right now this is a noop in the former case and a noop in the latter case unless lang/gcc44 has been installed explicitly. This puts a bit more emphasis on standardizing on a canonical version "current" GCC and makes it easier to update that canonical version by changing the default in Mk/bsd.gcc.mk and updating the lang/gcc port. That is, USE_GCC=yes means "use a decent/modern version of GCC" without having to worry about details. Approved by: portmgr (bdrewery)
Diffstat (limited to 'math')
-rw-r--r--math/fftw3/Makefile2
-rw-r--r--math/ised/Makefile2
-rw-r--r--math/p5-Math-Int128/Makefile2
-rw-r--r--math/py-graphtool/Makefile2
-rw-r--r--math/sage/Makefile2
5 files changed, 5 insertions, 5 deletions
diff --git a/math/fftw3/Makefile b/math/fftw3/Makefile
index e69d25bb5626..9ea1decf50c4 100644
--- a/math/fftw3/Makefile
+++ b/math/fftw3/Makefile
@@ -98,7 +98,7 @@ FFTW3_SUFX= q
FFTW3_PKGNAMESUFFIX= -quad
CONFIGURE_ARGS+=--enable-quad-precision
ONLY_FOR_ARCHS = i386 amd64
-USE_GCC= 4.6+
+USE_GCC= yes
.endif
.if ${FFTW3_FLAVOR} == "default"
diff --git a/math/ised/Makefile b/math/ised/Makefile
index cf363a7fea47..d92a098fee43 100644
--- a/math/ised/Makefile
+++ b/math/ised/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv3
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GCC= 4.6+
+USE_GCC= yes
MAN1= ${PORTNAME}.1
diff --git a/math/p5-Math-Int128/Makefile b/math/p5-Math-Int128/Makefile
index e01c8aa10915..f230395cc04d 100644
--- a/math/p5-Math-Int128/Makefile
+++ b/math/p5-Math-Int128/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= p5-Math-Int64>=0.28:${PORTSDIR}/math/p5-Math-Int64
USES= perl5
USE_PERL5= configure
-USE_GCC= 4.6+
+USE_GCC= yes
MAN3= Math::Int128.3 \
Math::Int128::die_on_overflow.3
diff --git a/math/py-graphtool/Makefile b/math/py-graphtool/Makefile
index 900dc71ce6d7..5c728300a7c8 100644
--- a/math/py-graphtool/Makefile
+++ b/math/py-graphtool/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= boost_python:${PORTSDIR}/devel/boost-python-libs \
CGAL.5:${PORTSDIR}/math/cgal
USE_BZIP2= yes
-USE_GCC= 4.6+
+USE_GCC= yes
USE_GMAKE= yes
USE_PYTHON= yes
GNU_CONFIGURE= yes
diff --git a/math/sage/Makefile b/math/sage/Makefile
index ae72774afca2..99b0a1d0a96c 100644
--- a/math/sage/Makefile
+++ b/math/sage/Makefile
@@ -29,7 +29,7 @@ OPTIONS_DEFINE_amd64= 387
PLIST_FILES= bin/sage
USE_FORTRAN= yes
-USE_GCC= 4.6+
+USE_GCC= yes
USE_TK= yes
USE_GMAKE= yes
USE_TEX= latex:build