aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2017-09-10 22:19:58 +0800
committertota <tota@FreeBSD.org>2017-09-10 22:19:58 +0800
commita1f934f7b197716ab35d4d1fd00097c18574aad0 (patch)
treed502172ea9f28c8c0343ce24a0d04200c6968dc4 /math
parent08f8181ad2cfdd5f196da21df2a4ea38d4cd4944 (diff)
downloadfreebsd-ports-gnome-a1f934f7b197716ab35d4d1fd00097c18574aad0.tar.gz
freebsd-ports-gnome-a1f934f7b197716ab35d4d1fd00097c18574aad0.tar.zst
freebsd-ports-gnome-a1f934f7b197716ab35d4d1fd00097c18574aad0.zip
- Add new port: math/R-cran-recipes
An extensible framework to create and preprocess design matrices. Recipes consist of one or more data manipulation and analysis "steps". Statistical parameters for the steps can be estimated from an initial data set and then applied to other data sets. The resulting design matrices can then be used as inputs into statistical or machine learning models. WWW: https://cran.r-project.org/web/packages/recipes/
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/R-cran-recipes/Makefile32
-rw-r--r--math/R-cran-recipes/distinfo3
-rw-r--r--math/R-cran-recipes/pkg-descr8
4 files changed, 44 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 1ed7d4972a73..d3d4e4eac3fa 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -77,6 +77,7 @@
SUBDIR += R-cran-qualityTools
SUBDIR += R-cran-quantreg
SUBDIR += R-cran-RcppRoll
+ SUBDIR += R-cran-recipes
SUBDIR += R-cran-rgenoud
SUBDIR += R-cran-sandwich
SUBDIR += R-cran-sf
diff --git a/math/R-cran-recipes/Makefile b/math/R-cran-recipes/Makefile
new file mode 100644
index 000000000000..8f57a6c7d063
--- /dev/null
+++ b/math/R-cran-recipes/Makefile
@@ -0,0 +1,32 @@
+# Created by: TAKATSU Tomonari <tota@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= recipes
+PORTVERSION= 0.1.0
+CATEGORIES= math
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Preprocessing Tools to Create Design Matrices
+
+LICENSE= GPLv2
+
+CRAN_DEPENDS= R-cran-dplyr>0:math/R-cran-dplyr \
+ R-cran-tibble>0:devel/R-cran-tibble \
+ R-cran-ipred>0:math/R-cran-ipred \
+ R-cran-dimRed>=0.1.0:math/R-cran-dimRed \
+ R-cran-lubridate>0:devel/R-cran-lubridate \
+ R-cran-timeDate>0:finance/R-cran-timeDate \
+ R-cran-ddalpha>0:math/R-cran-ddalpha \
+ R-cran-purrr>0:devel/R-cran-purrr \
+ R-cran-rlang>=0.1.1:devel/R-cran-rlang \
+ R-cran-gower>0:math/R-cran-gower \
+ R-cran-RcppRoll>0:math/R-cran-RcppRoll \
+ R-cran-tidyselect>=0.1.1:devel/R-cran-tidyselect \
+ R-cran-magrittr>0:devel/R-cran-magrittr
+BUILD_DEPENDS= ${CRAN_DEPENDS}
+RUN_DEPENDS= ${CRAN_DEPENDS}
+
+USES= cran:auto-plist
+
+.include <bsd.port.mk>
diff --git a/math/R-cran-recipes/distinfo b/math/R-cran-recipes/distinfo
new file mode 100644
index 000000000000..b88171be934e
--- /dev/null
+++ b/math/R-cran-recipes/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1504921818
+SHA256 (recipes_0.1.0.tar.gz) = 6ba689b5101f54d8b32844ee15cf0e8f4cee471e62fc3f36ab1d463c0099cd67
+SIZE (recipes_0.1.0.tar.gz) = 523958
diff --git a/math/R-cran-recipes/pkg-descr b/math/R-cran-recipes/pkg-descr
new file mode 100644
index 000000000000..277de9b54f5b
--- /dev/null
+++ b/math/R-cran-recipes/pkg-descr
@@ -0,0 +1,8 @@
+An extensible framework to create and preprocess design matrices.
+Recipes consist of one or more data manipulation and analysis
+"steps". Statistical parameters for the steps can be estimated from
+an initial data set and then applied to other data sets. The resulting
+design matrices can then be used as inputs into statistical or
+machine learning models.
+
+WWW: https://cran.r-project.org/web/packages/recipes/