aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-12-16 03:32:34 +0800
committerpav <pav@FreeBSD.org>2007-12-16 03:32:34 +0800
commita88e60fb75f4e69ccc0127fdb1d366177b882930 (patch)
tree2cff559067214743870fbfe0b43b4fd0b7de233e /math
parent3f6f6c31046174d5dd0f6dee904cad123e14636d (diff)
downloadfreebsd-ports-gnome-a88e60fb75f4e69ccc0127fdb1d366177b882930.tar.gz
freebsd-ports-gnome-a88e60fb75f4e69ccc0127fdb1d366177b882930.tar.zst
freebsd-ports-gnome-a88e60fb75f4e69ccc0127fdb1d366177b882930.zip
- Update to 1.6.0
PR: ports/118532 Submitted by: Pedro F. Giffuni <giffunip@tutopia.com> Approved by: Co Nijn <co9co9@gmail.com> (maintainer)
Diffstat (limited to 'math')
-rw-r--r--math/clp/Makefile17
-rw-r--r--math/clp/distinfo6
-rw-r--r--math/clp/pkg-plist5
3 files changed, 24 insertions, 4 deletions
diff --git a/math/clp/Makefile b/math/clp/Makefile
index b86a9f4c9811..b87b1626c70f 100644
--- a/math/clp/Makefile
+++ b/math/clp/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Clp
-PORTVERSION= 1.4.0
+PORTVERSION= 1.6.0
CATEGORIES= math
MASTER_SITES= http://www.coin-or.org/download/source/Clp/
EXTRACT_SUFX= .tgz
@@ -14,7 +14,22 @@ EXTRACT_SUFX= .tgz
MAINTAINER= co9co9@gmail.com
COMMENT= Linear Programming Solver
+LIB_DEPENDS= lapack.4:${PORTSDIR}/math/lapack
+.ifdef WITH_GMPL
+LIB_DEPENDS+= glpk.9:${PORTSDIR}/math/glpk
+.endif
+
+USE_FORTRAN= yes
+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+CONFIGURE_ENV+= ${MAKE_ENV}
+CONFIGURE_ARGS= --with-blas="-L${LOCALBASE}/lib -lblas" \
+ --with-lapack="-L${LOCALBASE}/lib -llapack"
+.ifdef WITH_GMPL
+CONFIGURE_ARGS+=--with-gmpl-incdir=${LOCALBASE}/include/gmpl \
+ --with-gmpl-lib="-L${LOCALBASE}/lib -lglpk"
+.endif
+
.include <bsd.port.mk>
diff --git a/math/clp/distinfo b/math/clp/distinfo
index f07f974e39ef..bcdd48da83c9 100644
--- a/math/clp/distinfo
+++ b/math/clp/distinfo
@@ -1,3 +1,3 @@
-MD5 (Clp-1.4.0.tgz) = e15af653c3f5db7d1943aa559d1c86af
-SHA256 (Clp-1.4.0.tgz) = 5a57b919cf76657392f16f4287271fbde72805adfe19b642c1c3fe547d8d624b
-SIZE (Clp-1.4.0.tgz) = 6884869
+MD5 (Clp-1.6.0.tgz) = 07295a5d25d33a50c32dcceb87cd3f7c
+SHA256 (Clp-1.6.0.tgz) = 6c17e2bc6dbe27be1a537299dcc21fe499bdfe078036ae73a9141b93b8351ee1
+SIZE (Clp-1.6.0.tgz) = 3103536
diff --git a/math/clp/pkg-plist b/math/clp/pkg-plist
index 58985b04aea7..c818f2207e1a 100644
--- a/math/clp/pkg-plist
+++ b/math/clp/pkg-plist
@@ -1,8 +1,12 @@
bin/clp
+include/CbcOrClpParam.hpp
include/ClpCholeskyBase.hpp
include/ClpCholeskyDense.hpp
include/ClpCholeskyWssmp.hpp
include/ClpConfig.h
+include/ClpConstraint.hpp
+include/ClpConstraintLinear.hpp
+include/ClpConstraintQuadratic.hpp
include/ClpDualRowDantzig.hpp
include/ClpDualRowPivot.hpp
include/ClpDualRowSteepest.hpp
@@ -75,6 +79,7 @@ include/CoinSearchTree.hpp
include/CoinShallowPackedVector.hpp
include/CoinSignal.hpp
include/CoinSmartPtr.hpp
+include/CoinSnapshot.hpp
include/CoinSort.hpp
include/CoinTime.hpp
include/CoinTypes.hpp