aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-05-29 18:53:43 +0800
committerbapt <bapt@FreeBSD.org>2012-05-29 18:53:43 +0800
commitc1519a49b2a32deb3401ad8f71cda4a0b0610c15 (patch)
tree8ff58dec7d3d8a19e7c939354226ed26aebcbdd5 /math
parent435be18558388014e6c3a8cad53f021515143c67 (diff)
downloadfreebsd-ports-gnome-c1519a49b2a32deb3401ad8f71cda4a0b0610c15.tar.gz
freebsd-ports-gnome-c1519a49b2a32deb3401ad8f71cda4a0b0610c15.tar.zst
freebsd-ports-gnome-c1519a49b2a32deb3401ad8f71cda4a0b0610c15.zip
- Convert to new option frame (mutualty exclusive options aka single)
- Should fix make index With hat: portmgr
Diffstat (limited to 'math')
-rw-r--r--math/maxima/Makefile29
1 files changed, 19 insertions, 10 deletions
diff --git a/math/maxima/Makefile b/math/maxima/Makefile
index 82a63c473ba3..ad470343cc5a 100644
--- a/math/maxima/Makefile
+++ b/math/maxima/Makefile
@@ -40,22 +40,29 @@ PLIST_SUB+= LISPBIN=${LISPBINARY}
PLIST_SUB+= MAXIMABIN=${MAXIMABINARY}
PLIST_SUB+= PORTVERSION=${PORTVERSION}
-OPTIONS= CLISP "Build with Clisp" off \
- CMUCL "Build with CMU Common Lisp" off \
- GCL "Build with GNU Common Lisp" off \
- SBCL "Build with Steel Bank Common Lisp" on
+OPTIONS_SINGLE= LISP
+OPTIONS_SINGLE_LISP= CLISP CMUCL GCL SBCL
+
+OPTIONS_DEFAULT= SBCL
+
+CLISP_DESC= Build with Clisp
+CMUCL_DESC= Build with CMU Common Lisp
+GCL_DESC= Build with GNU Common Lisp
+SBCL_DESC= Build with Steel Bank Common Lisp
.include <bsd.port.pre.mk>
# Lisp to build with. Define only ONE of these!
-.if defined(WITH_CLISP) && defined(WITHOUT_CMUCL) && defined(WITHOUT_GCL) && defined(WITHOUT_SBCL)
+.if ${PORT_OPTIONS:MCLISP}
LISPSELECT= --enable-clisp
LISPPORT= clisp:${PORTSDIR}/lang/clisp
BINDIRECTORY= binary-clisp
LISPBINARY= lisp.run
PLIST_SUB+= LISPBINARY=""
MAXIMABINARY= maxima.mem
-.elif defined(WITHOUT_CLISP) && defined(WITH_CMUCL) && defined(WITHOUT_GCL) && defined(WITHOUT_SBCL)
+.endif
+
+.if ${PORT_OPTIONS:MCMUCL}
LISPSELECT= --enable-cmucl
LISPPORT= lisp:${PORTSDIR}/lang/cmucl
BINDIRECTORY= binary-cmucl
@@ -63,14 +70,18 @@ LISPBINARY= lisp
PLIST_SUB+= LISPBINARY=""
MAXIMABINARY= maxima_core
STRIP= #strip(1) chokes on LISPBINARY
-.elif defined(WITHOUT_CLISP) && defined(WITHOUT_CMUCL) && defined(WITH_GCL) && defined(WITHOUT_SBCL)
+.endif
+
+.if ${PORT_OPTIONS:MGCL}
LISPSELECT= --enable-gcl
LISPPORT= gcl:${PORTSDIR}/lang/gcl
BINDIRECTORY= binary-gcl
#LISPBINARY is null so fudge this so deinstall works cleanly
PLIST_SUB+= LISPBINARY="@comment "
MAXIMABINARY= maxima
-.elif defined(WITHOUT_CLISP) && defined(WITHOUT_CMUCL) && defined(WITHOUT_GCL) && defined(WITH_SBCL)
+.endif
+
+.if ${PORT_OPTIONS:MSBCL}
. if ${ARCH} == "i386"
DYNAMIC_SPACE_SIZE?= 512
. else
@@ -89,8 +100,6 @@ BINDIRECTORY= binary-sbcl
#LISPBINARY is null so fudge this so deinstall works cleanly
PLIST_SUB+= LISPBINARY="@comment "
MAXIMABINARY= maxima_core
-.else
-IGNORE= define only one lisp
.endif
post-patch: