aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2011-03-26 09:39:07 +0800
committerbf <bf@FreeBSD.org>2011-03-26 09:39:07 +0800
commitc1a29c89b82fb519f9af9c0251a4c7e0e1424e26 (patch)
tree7bc2f45e34fa171c0322817028071776425112cf /math
parent47cf5b694da99d209a7f2c7f7f78d00584c77c25 (diff)
downloadfreebsd-ports-gnome-c1a29c89b82fb519f9af9c0251a4c7e0e1424e26.tar.gz
freebsd-ports-gnome-c1a29c89b82fb519f9af9c0251a4c7e0e1424e26.tar.zst
freebsd-ports-gnome-c1a29c89b82fb519f9af9c0251a4c7e0e1424e26.zip
Remove addition of CPPFLAGS to CONFIGURE_ENV
in port Makefiles, and MD5 entries in distinfo
Diffstat (limited to 'math')
-rw-r--r--math/gretl/Makefile3
-rw-r--r--math/jags/Makefile2
-rw-r--r--math/testu01/Makefile2
-rw-r--r--math/unuran/Makefile2
4 files changed, 4 insertions, 5 deletions
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index 52cfc501ca8a..5b429ad5ff8e 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -27,8 +27,7 @@ ALL_TARGET= # empty
CONFIGURE_ARGS = --enable-static --enable-shared --with-gmake --without-gnome
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
- LAPACK_LIBS="${LAPACK} ${BLAS}" \
+CONFIGURE_ENV= LAPACK_LIBS="${LAPACK} ${BLAS}" \
LDFLAGS="${LDFLAGS}"
MAN1= gretl.1
diff --git a/math/jags/Makefile b/math/jags/Makefile
index 409e0269286f..95ea07e0eba4 100644
--- a/math/jags/Makefile
+++ b/math/jags/Makefile
@@ -31,7 +31,7 @@ WRKSRC= ${WRKDIR}/${PKGNAME:S/mcmc-//:U}
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
USE_FORTRAN= yes
USE_LDCONFIG= yes
USE_BISON= build
diff --git a/math/testu01/Makefile b/math/testu01/Makefile
index 9d2c8d104310..59edb51be747 100644
--- a/math/testu01/Makefile
+++ b/math/testu01/Makefile
@@ -26,7 +26,7 @@ USE_GMAKE= yes
MAKE_ARGS= docdir="${DOCSDIR}" exdir="${EXAMPLESDIR}"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
CFLAGS+= -fPIC
PLIST_SUB= PORTNAME="${PORTNAME}"
diff --git a/math/unuran/Makefile b/math/unuran/Makefile
index 026b9d3b4f1d..5ac6492c41e7 100644
--- a/math/unuran/Makefile
+++ b/math/unuran/Makefile
@@ -23,7 +23,7 @@ CONFIGURE_ARGS= --enable-shared --with-urng-rngstream --with-urng-default=rngstr
--enable-info
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
MAKE_ENV= MAKE="${GMAKE}"
USE_LDCONFIG= yes