aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-09-09 06:04:45 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-09-09 06:04:45 +0800
commitceaaee42ad9854c5c1c8924cc0981f69df5ab2af (patch)
tree35a3e30340f9029ad93668332f996c181e982a8e /math
parent94e1ab7e994b098bbf19bfade2c65f6c64419276 (diff)
downloadfreebsd-ports-gnome-ceaaee42ad9854c5c1c8924cc0981f69df5ab2af.tar.gz
freebsd-ports-gnome-ceaaee42ad9854c5c1c8924cc0981f69df5ab2af.tar.zst
freebsd-ports-gnome-ceaaee42ad9854c5c1c8924cc0981f69df5ab2af.zip
- use SUB_FILES appropriately instead of SED directly
PR: ports/142812 Submitted by: Sevan Janiyan <venture37@geeklan.co.uk> Approved by: maintainer timeout (nivit ; 231 days)
Diffstat (limited to 'math')
-rw-r--r--math/mprime/Makefile12
-rw-r--r--math/mprime/files/pkg-message.in (renamed from math/mprime/pkg-message)4
-rw-r--r--math/mprime/files/wrapper.sh.in (renamed from math/mprime/files/wrapper.sh)0
3 files changed, 7 insertions, 9 deletions
diff --git a/math/mprime/Makefile b/math/mprime/Makefile
index 2c09ddc71f6e..6b4458a42fd9 100644
--- a/math/mprime/Makefile
+++ b/math/mprime/Makefile
@@ -18,15 +18,11 @@ ONLY_FOR_ARCHS= i386
NO_BUILD= yes
NO_WRKSUBDIR= yes
+SUB_FILES= pkg-message wrapper.sh
+
# source code version
SOURCE_VERSION= 24.14
-post-patch:
-# prepare wrapper
- @${SED} \
- -e 's|%%PREFIX%%|${PREFIX}|' ${FILESDIR}/wrapper.sh > \
- ${WRKDIR}/wrapper.sh
-
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/mprime ${PREFIX}/bin/mprime-real
@${INSTALL_SCRIPT} ${WRKDIR}/wrapper.sh ${PREFIX}/bin/mprime
@@ -36,6 +32,8 @@ do-install:
.endif
post-install:
- @${SED} -e 's|/usr/local/|${PREFIX}/|' ${PKGMESSAGE}
+.if !defined(NOPORTDOCS)
+ @${CAT} ${PKGMESSAGE}
+.endif
.include <bsd.port.mk>
diff --git a/math/mprime/pkg-message b/math/mprime/files/pkg-message.in
index 3c0c8b1aed04..46a39c0949cd 100644
--- a/math/mprime/pkg-message
+++ b/math/mprime/files/pkg-message.in
@@ -1,10 +1,10 @@
ATTENTIONATTENTION:
Please, make sure that you read
-/usr/local/share/doc/mprime/license.txt
+%%DOCSDIR%%/license.txt
and agree to the licensing terms before running this application.
Furthermore, read
-/usr/local/share/doc/mprime/readme.txt
+%%DOCSDIR%%/readme.txt
It contains important information about both configuring and running
mprime. You will have problems running it if you do not read it.
diff --git a/math/mprime/files/wrapper.sh b/math/mprime/files/wrapper.sh.in
index 3276091dc060..3276091dc060 100644
--- a/math/mprime/files/wrapper.sh
+++ b/math/mprime/files/wrapper.sh.in