aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorultima <ultima@FreeBSD.org>2017-07-21 04:23:47 +0800
committerultima <ultima@FreeBSD.org>2017-07-21 04:23:47 +0800
commitd88c4a83bf205520d20b2d636d7b2cc98ad11999 (patch)
tree1f2349f517a23a2c968bd5e41ad73642bd0854c8 /math
parentb45535cae769f7bd88b24b215a2886702e0377e7 (diff)
downloadfreebsd-ports-gnome-d88c4a83bf205520d20b2d636d7b2cc98ad11999.tar.gz
freebsd-ports-gnome-d88c4a83bf205520d20b2d636d7b2cc98ad11999.tar.zst
freebsd-ports-gnome-d88c4a83bf205520d20b2d636d7b2cc98ad11999.zip
* Updated to 1.8.2
* Update maintainer address * Included new dist sites * Stopped build in install stage * Sorted Makefile, Uses section is before option section[1]. Option section was also sorted to comply with[1]. [1] https://www.freebsd.org/doc/en/books/porters-handbook/porting-samplem.html#porting-samplem-order PR: 220741 Submitted by: Carsten Larsen <cs@innolan.net> (maintainer) Reviewed by: lifanov (mentor) Approved by: lifanov (mentor) Differential Revision: https://reviews.freebsd.org/D11663
Diffstat (limited to 'math')
-rw-r--r--math/amath/Makefile31
-rw-r--r--math/amath/distinfo6
-rw-r--r--math/amath/files/patch-configure42
3 files changed, 58 insertions, 21 deletions
diff --git a/math/amath/Makefile b/math/amath/Makefile
index 3a748e6ee4fe..0479ff507d50 100644
--- a/math/amath/Makefile
+++ b/math/amath/Makefile
@@ -1,40 +1,41 @@
# $FreeBSD$
PORTNAME= amath
-PORTVERSION= 1.8.0
+PORTVERSION= 1.8.2
CATEGORIES= math
-MASTER_SITES= http://suyai.innolan.net/ \
+MASTER_SITES= http://dist1.innolan.net/ \
+ http://dist2.innolan.net/ \
https://amath.innolan.net/
-MAINTAINER= cs@innolan.dk
+MAINTAINER= cs@innolan.net
COMMENT= Simple command line calculator
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+USES= gmake
+USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} --pkgconfig=libdata/pkgconfig \
+ --mandir=man LDFLAGS="-L${LOCALBASE}/lib"
+MAKE_ARGS= CC=${CC} CXX=${CXX}
+
OPTIONS_DEFINE= TESTS
-TESTS_DESC= Build with regression tests
+OPTIONS_DEFAULT=APPLIBM
OPTIONS_RADIO= LIBM
OPTIONS_RADIO_LIBM= APPLIBM OPENLIBM SYSLIBM
-LIBM_DESC= Math libraries
+OPTIONS_SUB= yes
APPLIBM_DESC= Build and install application libraries
+LIBM_DESC= Math libraries
OPENLIBM_DESC= Build with OpenLibm
SYSLIBM_DESC= System (-lm)
-OPTIONS_DEFAULT= APPLIBM TESTS
-OPTIONS_SUB= yes
+TESTS_DESC= Build with regression tests
-SYSLIBM_CONFIGURE_WITH= libm
OPENLIBM_CONFIGURE_WITH= openlibm
OPENLIBM_LIB_DEPENDS= libopenlibm.so:math/openlibm
+SYSLIBM_CONFIGURE_WITH= libm
TESTS_CONFIGURE_ENABLE= test
-USES= gmake
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --pkgconfig=libdata/pkgconfig \
- --mandir=man LDFLAGS="-L${LOCALBASE}/lib"
-USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
-MAKE_ARGS= CC=${CC} CXX=${CXX}
-ALL_TARGET= static
TEST_TARGET= test
post-install-APPLIBM-on:
diff --git a/math/amath/distinfo b/math/amath/distinfo
index b3bffb5e6997..7641b9ae4a0a 100644
--- a/math/amath/distinfo
+++ b/math/amath/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1492032535
-SHA256 (amath-1.8.0.tar.gz) = 63a32ac5512fac5421147c04f2fd500dc7b63c209706f225cfbf28ff90da6b0d
-SIZE (amath-1.8.0.tar.gz) = 258709
+TIMESTAMP = 1500068440
+SHA256 (amath-1.8.2.tar.gz) = cb8e58ac07020d142f9803cb8cfcf69aa5ece4697dbc12ff879a42f288f96ab2
+SIZE (amath-1.8.2.tar.gz) = 249450
diff --git a/math/amath/files/patch-configure b/math/amath/files/patch-configure
index 4d99fe5da306..426d6a930caf 100644
--- a/math/amath/files/patch-configure
+++ b/math/amath/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2017-04-03 12:17:53 UTC
+--- configure.orig 2017-04-21 22:00:00 UTC
+++ configure
-@@ -465,8 +465,6 @@ catanh.c
+@@ -512,8 +512,6 @@ catanh.c
ccos.c
ccosh.c
cexp.c
@@ -9,7 +9,7 @@
csin.c
csinh.c
csqrt.c
-@@ -485,6 +483,8 @@ ccot.c
+@@ -532,6 +530,8 @@ ccot.c
ccoth.c
ccsc.c
ccsch.c
@@ -18,3 +18,39 @@
clogb.c
clog10.c
csec.c
+@@ -781,7 +781,7 @@ echo "doc:"
+ echo " \${DOXYGEN} amatha.dox"
+ echo
+ echo ".PHONY: install"
+-echo "install: \${alib} \${solib}"
++echo "install:"
+ echo " \${MKDIR} \${INSTDIR}"
+ echo " \${MKDIR} \${INSTDIRPC}"
+ echo " \${MKDIR} \${INSTDIRI}"
+@@ -892,7 +892,7 @@ echo "doc:"
+ echo " \${DOXYGEN} amathc.dox"
+ echo
+ echo ".PHONY: install"
+-echo "install: \${alib} \${solib}"
++echo "install:"
+ echo " \${MKDIR} \${INSTDIR}"
+ echo " \${MKDIR} \${INSTDIRPC}"
+ echo " \${MKDIR} \${INSTDIRI}"
+@@ -991,7 +991,7 @@ echo "doc:"
+ echo " \${DOXYGEN} amathr.dox"
+ echo
+ echo ".PHONY: install"
+-echo "install: \${alib} \${solib}"
++echo "install: \${solib}"
+ echo " \${MKDIR} \${INSTDIR}"
+ echo " \${MKDIR} \${INSTDIRPC}"
+ echo " \${MKDIR} \${INSTDIRI}"
+@@ -1088,7 +1088,7 @@ echo "doc:"
+ echo " \${DOXYGEN} amathi.dox"
+ echo
+ echo ".PHONY: install"
+-echo "install: \${alib} \${solib}"
++echo "install:"
+ echo " \${MKDIR} \${INSTDIR}"
+ echo " \${MKDIR} \${INSTDIRPC}"
+ echo " \${MKDIR} \${INSTDIRI}"