aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2013-11-07 06:50:21 +0800
committerdelphij <delphij@FreeBSD.org>2013-11-07 06:50:21 +0800
commite152fec3d3565ef13abcbeb42f37c47f2788e9ca (patch)
treef4ca39f0f94b1fc725562cca278474e325706ee3 /math
parent43af442547bb63fc6c7117fbc9d483374293c063 (diff)
downloadfreebsd-ports-gnome-e152fec3d3565ef13abcbeb42f37c47f2788e9ca.tar.gz
freebsd-ports-gnome-e152fec3d3565ef13abcbeb42f37c47f2788e9ca.tar.zst
freebsd-ports-gnome-e152fec3d3565ef13abcbeb42f37c47f2788e9ca.zip
Update to 0.57.
PR: ports/179390 Submitted by: nemysis Approved by: maintainer
Diffstat (limited to 'math')
-rw-r--r--math/pure-mpfr/Makefile32
-rw-r--r--math/pure-mpfr/pkg-descr2
-rw-r--r--math/pure-rational/Makefile17
-rw-r--r--math/pure-rational/pkg-descr2
4 files changed, 43 insertions, 10 deletions
diff --git a/math/pure-mpfr/Makefile b/math/pure-mpfr/Makefile
index 51cb50b3ce2b..45bdd2c55cb6 100644
--- a/math/pure-mpfr/Makefile
+++ b/math/pure-mpfr/Makefile
@@ -3,19 +3,41 @@
PORTNAME= pure-mpfr
PORTVERSION= 0.4
+PORTREVISION= 1
CATEGORIES= math
+MASTER_SITES= https://cdn.bitbucket.org/purelang/pure-lang/downloads/
+DIST_SUBDIR= pure
MAINTAINER= lichray@gmail.com
COMMENT= Multiprecision floats for Pure
-USE_PURE= yes
-USES= pkgconfig
+LICENSE= GPLv3 LGPL3
+LICENSE_COMB= dual
+
+MAKE_ARGS+= libdir="${PREFIX}/lib"
+
+USES= pkgconfig pure
PLIST_FILES= lib/pure/mpfr.pure \
lib/pure/mpfr.so
-MAKE_ARGS+= libdir="${PREFIX}/lib"
-
NO_STAGE= yes
-.include "${.CURDIR}/../../lang/pure/bsd.pure.mk"
+
+PORTDOCS= README
+
+PORTEXAMPLES= *
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
+.endif
+
.include <bsd.port.mk>
diff --git a/math/pure-mpfr/pkg-descr b/math/pure-mpfr/pkg-descr
index ba226da0803b..fc6974abaf24 100644
--- a/math/pure-mpfr/pkg-descr
+++ b/math/pure-mpfr/pkg-descr
@@ -2,4 +2,4 @@ pure-mpfr makes the MPFR multiprecision floats (henceforth referred to as
mpfr numbers or values) available in Pure, so that they work with the other
types of Pure numbers in an almost seamless fashion.
-WWW: http://docs.pure-lang.googlecode.com/hg/pure-mpfr.html
+WWW: http://docs.pure-lang.googlecode.com/hg/pure-mpfr.html
diff --git a/math/pure-rational/Makefile b/math/pure-rational/Makefile
index 19df22fb7452..2f50e20ce1dd 100644
--- a/math/pure-rational/Makefile
+++ b/math/pure-rational/Makefile
@@ -5,18 +5,29 @@ PORTNAME= pure-rational
PORTVERSION= 0.1
PORTREVISION= 1
CATEGORIES= math
+MASTER_SITES= https://cdn.bitbucket.org/purelang/pure-lang/downloads/
+DIST_SUBDIR= pure
MAINTAINER= lichray@gmail.com
COMMENT= Rational number library for the Pure language
LICENSE= GPLv3
-USE_PURE= yes
-NO_PURE_EXAMPLES= yes
+USES= pure
PLIST_FILES= lib/pure/rational.pure \
lib/pure/rat_interval.pure
NO_STAGE= yes
-.include "${.CURDIR}/../../lang/pure/bsd.pure.mk"
+
+PORTDOCS= README
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>
diff --git a/math/pure-rational/pkg-descr b/math/pure-rational/pkg-descr
index 25a2d1bd43f1..89f3c90b3668 100644
--- a/math/pure-rational/pkg-descr
+++ b/math/pure-rational/pkg-descr
@@ -1,4 +1,4 @@
pure-rational provides additional operations on the rational number type
provided by the math.pure module in the standard library.
-WWW: http://docs.pure-lang.googlecode.com/hg/pure-rational.html
+WWW: http://docs.pure-lang.googlecode.com/hg/pure-rational.html