aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-10-29 01:13:24 +0800
committerjbeich <jbeich@FreeBSD.org>2016-10-29 01:13:24 +0800
commite15df12463503ab0540af02e66bbe48a6ed9c54c (patch)
treebcf31c1c1134eed4d9f6bab5ee5e0d85f08e8b08 /math
parent830b886bac7f7a8a2b3b7248f339281119be7cd4 (diff)
downloadfreebsd-ports-gnome-e15df12463503ab0540af02e66bbe48a6ed9c54c.tar.gz
freebsd-ports-gnome-e15df12463503ab0540af02e66bbe48a6ed9c54c.tar.zst
freebsd-ports-gnome-e15df12463503ab0540af02e66bbe48a6ed9c54c.zip
math/py-numpy: track PORTEPOCH in consumers
Diffstat (limited to 'math')
-rw-r--r--math/nlopt/Makefile4
-rw-r--r--math/py-colormath/Makefile2
-rw-r--r--math/py-luminol/Makefile2
-rw-r--r--math/py-networkx/Makefile2
-rw-r--r--math/py-numexpr/Makefile2
-rw-r--r--math/py-pysparse/Makefile4
6 files changed, 8 insertions, 8 deletions
diff --git a/math/nlopt/Makefile b/math/nlopt/Makefile
index c1d09e1ab0fc..6727e7966b85 100644
--- a/math/nlopt/Makefile
+++ b/math/nlopt/Makefile
@@ -17,8 +17,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libgmp.so:math/gmp \
libguile-2.0.so:lang/guile2
BUILD_DEPENDS= swig3.0:devel/swig30 \
- ${PYTHON_PKGNAMEPREFIX}numpy>=1.9.1:math/py-numpy
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.9.1:math/py-numpy
+ ${PYTHON_PKGNAMEPREFIX}numpy>=1.9.1,1:math/py-numpy
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.9.1,1:math/py-numpy
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared
diff --git a/math/py-colormath/Makefile b/math/py-colormath/Makefile
index e770bb034f5b..6532b964c53a 100644
--- a/math/py-colormath/Makefile
+++ b/math/py-colormath/Makefile
@@ -12,7 +12,7 @@ COMMENT= Module that spares the user from directly dealing with color math
LICENSE= BSD2CLAUSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.9.2:math/py-numpy \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.9.2,1:math/py-numpy \
${PYTHON_PKGNAMEPREFIX}networkx>=1.9.1:math/py-networkx
USES= python
diff --git a/math/py-luminol/Makefile b/math/py-luminol/Makefile
index ff4ea9676ec9..ef17e9c41e25 100644
--- a/math/py-luminol/Makefile
+++ b/math/py-luminol/Makefile
@@ -13,7 +13,7 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy \
- ${PYTHON_PKGNAMEPREFIX}numpy>=1.6.2:math/py-numpy
+ ${PYTHON_PKGNAMEPREFIX}numpy>=1.6.2,1:math/py-numpy
USES= python
USE_PYTHON= autoplist distutils
diff --git a/math/py-networkx/Makefile b/math/py-networkx/Makefile
index 005b1ffc3e58..4216caeca3fd 100644
--- a/math/py-networkx/Makefile
+++ b/math/py-networkx/Makefile
@@ -32,7 +32,7 @@ OPTIONS_GROUP_RENDER= MPL GRAPHVIZ
OPTIONS_DEFAULT= NUMPY SCIPY MPL GRAPHVIZ YAML
NUMPY_DESC= Matrix representation of graphs
-NUMPY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.9.2:math/py-numpy
+NUMPY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.9.2,1:math/py-numpy
SCIPY_DESC= Sparse matrix representation of graphs
SCIPY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}scipy>=0.15.1:science/py-scipy \
diff --git a/math/py-numexpr/Makefile b/math/py-numexpr/Makefile
index 1c79326bfb54..cc6f1fd6226a 100644
--- a/math/py-numexpr/Makefile
+++ b/math/py-numexpr/Makefile
@@ -13,7 +13,7 @@ COMMENT= Fast numerical array expression evaluator for Python and NumPy
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.6:math/py-numpy
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.6,1:math/py-numpy
RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PYTHON= autoplist concurrent distutils
diff --git a/math/py-pysparse/Makefile b/math/py-pysparse/Makefile
index c2e3490ff34d..8c7eccf59d23 100644
--- a/math/py-pysparse/Makefile
+++ b/math/py-pysparse/Makefile
@@ -13,8 +13,8 @@ COMMENT= Fast sparse matrix library for Python
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.2:math/py-numpy
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.2:math/py-numpy
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.2,1:math/py-numpy
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.2,1:math/py-numpy
LIB_DEPENDS= liblapack.so:math/lapack \
libblas.so:math/blas \
libopenblas.so:math/openblas \