aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authortruckman <truckman@FreeBSD.org>2012-06-07 04:49:07 +0800
committertruckman <truckman@FreeBSD.org>2012-06-07 04:49:07 +0800
commit1609e062ea62305202a114d3efc382722fbd1669 (patch)
tree36565a3bc940cd088227bcfefd3f2b165cb2a261 /math
parent009ca785cf2e3d3e443665d70476b41bd989008c (diff)
downloadfreebsd-ports-gnome-1609e062ea62305202a114d3efc382722fbd1669.tar.gz
freebsd-ports-gnome-1609e062ea62305202a114d3efc382722fbd1669.tar.zst
freebsd-ports-gnome-1609e062ea62305202a114d3efc382722fbd1669.zip
Unbreak package builds on pointyhat cluster by adding the missing
unzip dependency. Add a post-extract target to copy the .jar files from distfiles to the thirdparty directory instead of doing this as part of post-patch. Slightly re-order the contents of Makefile to get rid of some new portlint warnings introduced in rev 1.89. Reported by: pav@ and bapt@ from pointyhat error logs Approved by: Rob Farmer <rfarmer AT predatorlabs.net> (maintainer)
Diffstat (limited to 'math')
-rw-r--r--math/scilab/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index ac93bc31627f..50c7d8da72aa 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -19,10 +19,7 @@ EXTRACT_ONLY= ${DISTNAME}-src.tar.gz
MAINTAINER= rfarmer@predatorlabs.net
COMMENT= Scientific software package for numerical computations
-SAXON_VERSION= 6.5.5
-SAXON_DISTFILE= saxon${SAXON_VERSION:S/./-/g}.zip
-DISTFILES+= ${SAXON_DISTFILE}:saxon
-
+EXTRACT_DEPENDS+= ${UNZIP_CMD}:${PORTSDIR}/archivers/unzip
# A partial dependencies list can be found at:
# http://wiki.scilab.org/Dependencies_of_Scilab_5.X
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
@@ -84,6 +81,10 @@ CONFIGURE_ARGS+= --with-tk-library=${LOCALBASE}/lib \
--with-tcl-include=${TCL_INCLUDEDIR}
.endif
+SAXON_VERSION= 6.5.5
+SAXON_DISTFILE= saxon${SAXON_VERSION:S/./-/g}.zip
+DISTFILES+= ${SAXON_DISTFILE}:saxon
+
.if defined(WITHOUT_GUI)
CONFIGURE_ARGS+= --without-gui \
--without-javasci \
@@ -195,6 +196,13 @@ PLIST_SUB+= OCAML=""
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-NOPORTDOCS
.endif
+post-extract:
+ @${MKDIR} ${WRKSRC}/thirdparty
+ @${UNZIP_CMD} ${DISTDIR}/${SAXON_DISTFILE} saxon.jar -d ${WRKSRC}/thirdparty
+.if !defined(WITHOUT_GUI)
+ @${CP} ${DISTDIR}/${JGRAPHX_JAR} ${WRKSRC}/thirdparty/jgraphx.jar
+.endif
+
post-patch:
@# Configure fixes
@${REINPLACE_CMD} -e 's|-ldl | |' ${WRKSRC}/configure
@@ -217,8 +225,6 @@ post-patch:
@# Run fixes
@${REINPLACE_CMD} -e 's|%%JAVALIBDIR%%|${JAVALIBDIR}|' ${WRKSRC}/etc/librarypath.xml
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/etc/librarypath.xml
- @${MKDIR} ${WRKSRC}/thirdparty
- @${UNZIP_CMD} ${DISTDIR}/${SAXON_DISTFILE} saxon.jar -d ${WRKSRC}/thirdparty
.if !defined(WITHOUT_GUI)
@# Configure fixes
@${REINPLACE_CMD} -e 's|/usr/lib/java|${JAVALIBDIR}|g' ${WRKSRC}/configure
@@ -228,7 +234,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|$$jardir/jeuclid-core*.jar|${LOCALBASE}/share/java/jeuclid/repo/jeuclid-core*.jar|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|jrosetta-API.jar|jrosetta-api.jar|' \
${WRKSRC}/configure
- @${CP} ${DISTDIR}/${JGRAPHX_JAR} ${WRKSRC}/thirdparty/jgraphx.jar
@# Run fixes
@${REINPLACE_CMD} -e 's|%%JAVALIBDIR%%|${JAVALIBDIR}|' ${WRKSRC}/etc/librarypath.xml
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/etc/librarypath.xml