aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2014-09-14 07:39:20 +0800
committerjhale <jhale@FreeBSD.org>2014-09-14 07:39:20 +0800
commit0bd35e92c16bd05ae5f5df914f465dd7e1d61b2a (patch)
tree3e8089a10a2c39b7f023e578ac35c4ecba15f67a /math
parent9a8a7379e7f406201894d600e3cd5defe8020b11 (diff)
downloadfreebsd-ports-gnome-0bd35e92c16bd05ae5f5df914f465dd7e1d61b2a.tar.gz
freebsd-ports-gnome-0bd35e92c16bd05ae5f5df914f465dd7e1d61b2a.tar.zst
freebsd-ports-gnome-0bd35e92c16bd05ae5f5df914f465dd7e1d61b2a.zip
- Since Python 3.x packages aren't available, add a check to
prevent pkg-fallout errors ===> rpcalc-0.7.0 depends on package: py33-qt4-gui>=0 - not found ===> Verifying install for py33-qt4-gui>=0 in /usr/ports/x11-toolkits/py-qt4-gui ===> rpcalc-0.7.0 depends on package: /packages/All/py33-qt4-gui-4.11.1,1.txz - not found ===> USE_PACKAGE_DEPENDS_ONLY set - not building missing dependency from source *** Error code 1
Diffstat (limited to 'math')
-rw-r--r--math/rpcalc/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/math/rpcalc/Makefile b/math/rpcalc/Makefile
index a34c4703d75e..15559323341f 100644
--- a/math/rpcalc/Makefile
+++ b/math/rpcalc/Makefile
@@ -40,4 +40,10 @@ do-install:
${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py \
-d ${DATADIR} -f ${DATADIR_REL})
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(PACKAGE_BUILDING) && ${PYTHON_VER} != ${PYTHON_DEFAULT}
+IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
+.endif
+
+.include <bsd.port.post.mk>