aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-10-12 01:55:01 +0800
committerkwm <kwm@FreeBSD.org>2015-10-12 01:55:01 +0800
commit1b07dfac512433b5fd1f7d74f730f4ff87978cb4 (patch)
tree0b23b931ca9094a5d1ed5a085d62d468a343af2c /math
parentc43dcaa8bc320f121f8e2e779cc23b8166eb6853 (diff)
downloadfreebsd-ports-gnome-1b07dfac512433b5fd1f7d74f730f4ff87978cb4.tar.gz
freebsd-ports-gnome-1b07dfac512433b5fd1f7d74f730f4ff87978cb4.tar.zst
freebsd-ports-gnome-1b07dfac512433b5fd1f7d74f730f4ff87978cb4.zip
* OpenCL is not available on 9.3-R.
* Add patch to clfft to fix the build. * Use correct LICENSE in clrng. Submitted by: maintainer@
Diffstat (limited to 'math')
-rw-r--r--math/clblas/Makefile2
-rw-r--r--math/clfft/Makefile2
-rw-r--r--math/clfft/files/patch-src_statTimer_statisticalTimer.h10
-rw-r--r--math/clrng/Makefile4
4 files changed, 14 insertions, 4 deletions
diff --git a/math/clblas/Makefile b/math/clblas/Makefile
index c7641ee7406f..5409ba122266 100644
--- a/math/clblas/Makefile
+++ b/math/clblas/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= opencl>=0:${PORTSDIR}/devel/opencl
LIB_DEPENDS= libOpenCL.so:${PORTSDIR}/devel/ocl-icd
RUN_DEPENDS= opencl>=0:${PORTSDIR}/devel/opencl
-ONLY_FOR_ARCHS= amd64
+BROKEN_FreeBSD_9= clBLAS is only supported on FreeBSD 10.1 and newer
USE_GITHUB= yes
GH_ACCOUNT= clMathLibraries
diff --git a/math/clfft/Makefile b/math/clfft/Makefile
index 2f2c049bab62..10e8cb53ea9b 100644
--- a/math/clfft/Makefile
+++ b/math/clfft/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= opencl>=0:${PORTSDIR}/devel/opencl
LIB_DEPENDS= libOpenCL.so:${PORTSDIR}/devel/ocl-icd
RUN_DEPENDS= opencl>=0:${PORTSDIR}/devel/opencl
-ONLY_FOR_ARCHS= amd64
+BROKEN_FreeBSD_9= clFFT is only supported on FreeBSD 10.1 and newer
USE_GITHUB= yes
GH_ACCOUNT= clMathLibraries
diff --git a/math/clfft/files/patch-src_statTimer_statisticalTimer.h b/math/clfft/files/patch-src_statTimer_statisticalTimer.h
new file mode 100644
index 000000000000..ae92e4dd8b91
--- /dev/null
+++ b/math/clfft/files/patch-src_statTimer_statisticalTimer.h
@@ -0,0 +1,10 @@
+--- src/statTimer/statisticalTimer.h.orig 2015-10-11 19:43:16.998055000 +0200
++++ src/statTimer/statisticalTimer.h 2015-10-11 19:44:10.217558000 +0200
+@@ -21,6 +21,7 @@
+ #include <vector>
+ #include <functional>
+ #include <string>
++#include <sys/time.h>
+
+ #include "../include/clFFT.h"
+
diff --git a/math/clrng/Makefile b/math/clrng/Makefile
index 1d361f8b5669..8621fced9847 100644
--- a/math/clrng/Makefile
+++ b/math/clrng/Makefile
@@ -9,14 +9,14 @@ CATEGORIES= math
MAINTAINER= dieterich@ogolem.org
COMMENT= Library for uniform random number generation in OpenCL
-LICENSE= BSD
+LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= opencl>=0:${PORTSDIR}/devel/opencl
LIB_DEPENDS= libOpenCL.so:${PORTSDIR}/devel/ocl-icd
RUN_DEPENDS= opencl>=0:${PORTSDIR}/devel/opencl
-ONLY_FOR_ARCHS= amd64
+BROKEN_FreeBSD_9= clRNG is only supported on FreeBSD 10.1 and newer
USE_GITHUB= yes
GH_ACCOUNT= clMathLibraries