aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-04-19 05:03:41 +0800
committerpav <pav@FreeBSD.org>2005-04-19 05:03:41 +0800
commit224324eb5756b946b6b8c80f2c68cb02618c530c (patch)
treed2e6e4b07bb47c5acaa81a72cc8da48a98057e0f /math
parent415a17d5f2b3b1053876f802d40cc1ba5bf3e910 (diff)
downloadfreebsd-ports-gnome-224324eb5756b946b6b8c80f2c68cb02618c530c.tar.gz
freebsd-ports-gnome-224324eb5756b946b6b8c80f2c68cb02618c530c.tar.zst
freebsd-ports-gnome-224324eb5756b946b6b8c80f2c68cb02618c530c.zip
- Point to tcl/tk includes [1]
- Fix packing PR: ports/79914 [1] Submitted by: George V. Kouryachy <frbrgeorge@gmail.com> The port is still quite broken.
Diffstat (limited to 'math')
-rw-r--r--math/py-matplotlib/Makefile3
-rw-r--r--math/py-matplotlib/files/patch-setupext.py3
2 files changed, 4 insertions, 2 deletions
diff --git a/math/py-matplotlib/Makefile b/math/py-matplotlib/Makefile
index 77bb6fdc2e43..265f7b5c20e4 100644
--- a/math/py-matplotlib/Makefile
+++ b/math/py-matplotlib/Makefile
@@ -36,7 +36,8 @@ CFLAGS+= -I${X11BASE}/include
DATADIR= ${PREFIX}/share/py-${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
-PLISTDIR= ${PYTHON_SITELIBDIR}/${PORTNAME} ${DATADIR}
+PLISTDIR= ${PYTHON_SITELIBDIR}/${PORTNAME} ${PYTHON_SITELIBDIR}/dateutil ${PYTHON_SITELIBDIR}/pytz \
+ ${PYTHON_SITELIBDIR}/pylab* ${DATADIR}
.if !defined(NOPORTDOCS)
PLISTDIR+= ${EXAMPLESDIR}
.endif
diff --git a/math/py-matplotlib/files/patch-setupext.py b/math/py-matplotlib/files/patch-setupext.py
index 80f73ba0f8f2..0030563cf3da 100644
--- a/math/py-matplotlib/files/patch-setupext.py
+++ b/math/py-matplotlib/files/patch-setupext.py
@@ -2,7 +2,8 @@
+++ setupext.py Tue Apr 12 16:10:28 2005
@@ -308,7 +308,7 @@
o = find_tcltk() # todo: try/except
- module.include_dirs.extend([o.tcl_inc, o.tk_inc])
+- module.include_dirs.extend([o.tcl_inc, o.tk_inc])
++ module.include_dirs.extend(["/usr/local/include/tcl8.4", "/usr/local/include/tk8.4"])
module.library_dirs.extend([o.tcl_lib, o.tk_lib])
- module.libraries.extend(['tk'+o.tkv, 'tcl'+o.tkv])
+ module.libraries.extend(['tk84', 'tcl84'])