aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-04-11 02:18:09 +0800
committerswills <swills@FreeBSD.org>2011-04-11 02:18:09 +0800
commit281bb1cc1dbe6939d53f27733cf8d537050e20dc (patch)
treea39d720d5dc4e88e9d857aa56f5975a7da5ffc57 /math
parent5ab67ad7a6d341b9e28e7508912c27da5cd45c4c (diff)
downloadfreebsd-ports-gnome-281bb1cc1dbe6939d53f27733cf8d537050e20dc.tar.gz
freebsd-ports-gnome-281bb1cc1dbe6939d53f27733cf8d537050e20dc.tar.zst
freebsd-ports-gnome-281bb1cc1dbe6939d53f27733cf8d537050e20dc.zip
- Mark broken with Ruby 1.9
Diffstat (limited to 'math')
-rw-r--r--math/ruby-bitset/Makefile6
-rw-r--r--math/ruby-bitvector/Makefile6
-rw-r--r--math/ruby-gmp/Makefile4
3 files changed, 14 insertions, 2 deletions
diff --git a/math/ruby-bitset/Makefile b/math/ruby-bitset/Makefile
index 7b4ed4880e91..2bdbda5a32df 100644
--- a/math/ruby-bitset/Makefile
+++ b/math/ruby-bitset/Makefile
@@ -26,4 +26,8 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/sample/* ${RUBY_MODEXAMPLESDIR}/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/math/ruby-bitvector/Makefile b/math/ruby-bitvector/Makefile
index f7e21da22d60..4e40c2671a7f 100644
--- a/math/ruby-bitvector/Makefile
+++ b/math/ruby-bitvector/Makefile
@@ -30,4 +30,8 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/math/ruby-gmp/Makefile b/math/ruby-gmp/Makefile
index b951a0d47655..bebedef858b4 100644
--- a/math/ruby-gmp/Makefile
+++ b/math/ruby-gmp/Makefile
@@ -29,6 +29,10 @@ DOCS= ChangeLog README doc/PRECISION doc/TODO
.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODDOCDIR}